Question My TP Link TL-WN881ND stopped working all of a sudden

matthewraagas87

Prominent
Jun 11, 2018
26
0
530
0
Hello everyone, for some reason while I was using my PC that network connection to the my wifi router suddenly lost connection after playing a game. The first thing I checked was the device manager and saw that there was a yellow icon over the pcie wifi adapter. I have tried to disable the adapter and re-enable, delete the driver and reinstall the driver and have removed the physical adapter from the PC and back in again. Not of these things that I have tried did not solve the issue, I am thinking if the actually wifi card is fried/broken and plus there is a LED indicating if it is working or not which should be green but it is turned off. Normally I would see a solid green light or flashing so that it is actually working. Can anyone help me with this issue.
 

Phillip Corcoran

Titan
Moderator
Easiest and quickest way to proceed is to replace that WiFi card with a new one --- all indications are that it's dead. Often there is no better way of diagnosing a problem, especially when the affected device is relatively cheap to replace.

I always keep a spare network card in my computer cupboard, other cheapish items too like spare mouse & keyboard etc. Learned that from my boy scouts days, "Be prepared".
 

matthewraagas87

Prominent
Jun 11, 2018
26
0
530
0
I pretty sure that the wifi card is actually busted now but I thought could the pcie port on the motherboard be broken or mainly just the wifi card itself. The wifi card only cost $29 aud. What wifi card would you recommend?
 

ASK THE COMMUNITY

TRENDING THREADS