Question My video card doesn't work, only the integrated graphics are displaying video

andrei391

Prominent
Jun 10, 2018
3
0
510
0
Hi, I recently managed to "repair" my PC, but I have a new problem, the video card is not being detected and it doesn't show any image, only the integrated graphics from the motherboard are working, this is a common issue to be honest, it happened to me a lot but I'm start to think that this might be the real death of my card, the fans are spinning, don't know what to do anymore... do you have any ideas? Thanks beforehand

CPU: Fx 6300
Motherboard: AsRock N68-GS4 (the 2.0 USB version)
RAM: Adata DDR3 1600 mhz
GPU: Gigabyte R7 250 2gb (the DDR3 version)
HDD: Hitachi hua72201
PSU: A generic 500w (it never gave me problems)
Chassis: Eagle Warrior 06R0
OS: Windows 10 Pro 64 bits
 
Last edited:

Lutfij

Titan
Moderator
List your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

What have you tried thus far to think it's your discrete GPU, this time? Might want to bring us up to speed on how you repaired your system.
 

andrei391

Prominent
Jun 10, 2018
3
0
510
0
List your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

What have you tried thus far to think it's your discrete GPU, this time? Might want to bring us up to speed on how you repaired your system.
Done :) Someone put the ram stick in the wrong DIM and I wasn't familiarized with the mobo so I had to do some research first and then I figure out that I had to swap the ram stick and done, but the card doesn't seem to work
 
Last edited:

ASK THE COMMUNITY