Question My WD Elements drops in speed before eventually disconnecting from my PC after a while ?

Florisvengelen

Distinguished
Oct 6, 2013
16
0
18,510
0
When I connect my WD Elements external HDD I can see the files it contains, I can click on the files and view them, but after around 1 minute, the drive's read-speed drops and eventually dies completely. I can quickly transfer files from it but I can't consistently use it anymore. Is it broken? Could it be the Micro USB 3.0 cable?
 

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information,.

How many other USB devices are connected to the computer? Are all of them dependent on system USB power versus some independent power source of their own. Or maybe via an independently powered USB hub.

If you have another known working cable then try it just as a matter of elimination.

= = = =

Open Either Task Manager or Resource Monitor to observe system performance.

Use both tools but only one tool at a time.

With the tool window open connect to the WD Elements external HDD and do as you normally do.

Watch carefully to see what happens or starts happening abound that 1 minute mark. Some app, utility starts, stops, grabs resources, etc..

Another tool that can help is Process Explorer. Microsoft, free.

https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer

May take a few trial and error attempts to get a sense of it all. However, there is a good chance that you will spot some potential culprit.
 

ASK THE COMMUNITY