My windows 7 install does not detect my hard drive but bios does.

Status
Not open for further replies.

James_north

Honorable
Sep 29, 2013
6
0
10,510
0
Specs: Gigabyte motherboard Z68XP-UD3 socket 1155
Hdd Seagate 1TB Barracuda Internal Hard Drive - OEM
I am able to detect the hdd is the bios setttings and able to boot from the hdd but window 7 pro does not detect the hdd saying i need to load driver. I cannot find these drivers on the install disk or the gigabyte utility dvd. Can anyone help me ?
 

popatim

Titan
Moderator
This is a bit more complex as your motherbd has Intel and Marvell controller built in. Make sure the hard drive (HDD) is plugged into the sata port labelled SATA3_1 (saving sata3_0 for an ssd in the future)

Next go into the bios and make sure the sata port type is set to AHCI

Now reboot and install windows :)

The issue is either you are plugged into the Marvell controller or your sata types are set to raid, both of which would require a driver to load like you are seeing.
 

James_north

Honorable
Sep 29, 2013
6
0
10,510
0


thank you for the quick reply, however I have put the sata connection into the Sata3_1 port which I then confirmed in the bios. I then set the PCH Sata control mode to AHCI like you and the instruction manual suggested, after this the hard drive does not appear in the bios but still appears as a bootable device after pressing 'f12' and when trying to install windows 7 pro the hard drive still does not appear and asks me to load drivers. Can anyone help me or does anyone know what to do?
 

projmic

Reputable
Feb 15, 2014
1
0
4,510
0


Had the same problem, after much experimentation I stumbled across the solution. Hope it works for you

Found a way how to fix a SATA hard drive that is seen in setup but not seen in Win 7 installation. Just finished recovering 5 SATA hard drives of various sizes with this method. It’s a bit involved but it works. What has happened is that the boot sector on the hard drive has been lost or corrupted.
Make sure that the setup for SATA drives is NOT in ACHI

You will need a computer with a Floppy A drive, a Win 98 floppy boot disk, and an XP installation disk.
Go into set up and select Floppy A 3 1/2 inch in the number 1 position of the boot sequence .

Insert Win 98 floppy into the floppy drive and restart computer (hope you are familiar with old DOS)

Let the computer boot up from the disk and answer the prompts until you get the A:\ prompt and type “fdisk”

When the new screen comes up you will need to delete all other partitions on the hard drive and create a new “FAT32” partition on the drive. If you are not familiar with DOS just try follow the prompts and answer questions as they appear.

If all went well with the process you will now have a bootable sector on the hard drive. However Win 7 does not recognize FAT 32. It requires NTSF. Here is where XP installation disk comes into play.

Insert XP disk in CD/Rom and reboot and allow the setup begin. Once the beginning files are copied, you will be asked to install or use the Recovery Console. Choose “R” to run the Recovery Console. Let it run until you see the C:\ prompt and type “fixboot”.
Let it run, reply to the options and you will now have installed a new NTSF boot sector on the hard drive.
The hard drive will now allow you to clean install Win 7 or XP.

Good luck


 

electricsnake

Honorable
Dec 6, 2013
125
0
10,690
3
hope this works for u,i just solved my problem using this :D

open cmd(command prompt) through windows installation,u can find it on repair my computer
type diskpart
then u type select disk <x> where the <x> is the drive u want to use
then type clean and done
check the disk partition in custom installation
and here u go,windows installation :D
 

TimTacToe

Reputable
Jul 2, 2014
1
0
4,510
0


Thank you so much this worked and was easy. I have tried every other option and nothing worked. Thank you very much!
 

electricsnake

Honorable
Dec 6, 2013
125
0
10,690
3


your welcome sir :D
 

offbeatdave

Reputable
Oct 4, 2014
1
0
4,510
0
Just wanted to say thanks. This worked perfectly. I inherited a system where HDD had been scrubbed but wasn't being detected. This took seconds and fixed the issue.



 

electricsnake

Honorable
Dec 6, 2013
125
0
10,690
3


your welcome and have a nice day :D

 

rabi340

Reputable
Oct 9, 2014
2
0
4,510
0
I'm now suffering from same problem. I have tried to solve it using the cmd mode, but couldn't understand what will be the drive name as shown. ..
DISKPART > select disk....than what and how? What is to type in place of <x> as told by electricsnake...?
 

Simon Wilson 65535

Reputable
Nov 7, 2014
1
0
4,510
0
Just posting to say thanks for the solution, after 5 hours of transferring self-extractables to floppy to flash drives to windows folders this worked within a single minute. My hero.

You can see your disk ID by opening the Disk Management window and looking down the left hand side of the partitions.
Type DETAIL DISK to ensure you have selected the correct drive. Double-checking is your friend,
 
Status
Not open for further replies.

ASK THE COMMUNITY