[SOLVED] [MYSTERY] I swear I'm not crazy - PC loses power and reboots when gaming with VSYNC on! (Your thoughts appreciated)

Status
Not open for further replies.
May 23, 2020
2
1
15
0
Hi all,

I have a relatively new gaming PC (built it back in February). Since putting it all together, I've had issues with intermittent crashes whilst gaming - the PC completely loses power, reboots, hangs on the motherboard manufacturer's logo for a few minutes, then loads back into Windows. It was happening infrequently enough that it didn't really bother me, but recently I started playing Frostpunk and was experiencing the problem every single time I tried to play the game, which led to me looking for a solution.

Having tried various things from a hardware point of view (reseating the GPU, RAM, CPU, CPU cooler and all power cables) to no avail, I went down the software side of things instead - here's a summary of what I did:
  • Memory testing using Windows' built-in error-checking tool, and also with MemTest86
  • GPU stress-testing using Furmark
  • GPU/PSU/CPU stress-testing using using OCCT
  • Complete uninstallation of ALL nVidia-related drivers and software using DDU/Windows Add or Remove Programs, followed by re-installation of the latest versions
  • Pretty much constant monitoring of hardware temperatures/fan RPMs throughout all of the above
  • Messing around with my monitor's built-in settings (disabled AMD FreeSync, nothing much else to change)
Long story short, NONE of the above helped at all - Frostpunk continued to crash almost immediately after entering the game, until - as a last resort, having tried everything else I could think of) - I disabled VSYNC.

Problem solved. No crashes.

Although I'm obviously pleased that I can play my new game, I'm concerned that this might represent some kind of underlying issue which remains unaddressed - from what I can gather, having VSYNC turned on should help reduce load on the GPU, so I can't understand how having it turned off could be helping the issue - could it all be driver-related?

For reference, my PC specs are as follows:
  • Gigabyte Z390 UD Intel Socket 1151 Motherboard (rev 1.0, latest BIOS installed, recently reverted to stock BIOS settings as part of my troubleshooting)
  • Intel Core i7 9700K 3.6GHz 8 Core CPU (running at stock)
  • Corsair Vengeance RGB PRO 32GB (4x 8GB) 3200MHz (running at stock)
  • Gigabyte GeForce RTX 2070 SUPER Windforce OC 3X 8G (rev 1.0, running at stock, BIOS 90.4.86.0.d0 (up to date), nVidia driver 26.21.14.4292 (up to date))
  • Corsair CX750M Builder Series 750W Modular PSU (voltages perfect when checked in BIOS)
  • Cooler Master MasterLiquid ML240L RGB All-In-One Liquid CPU Cooler (functioning!)
  • Adata Ultimate SU650 960GB 2.5" SATA III SSD (system)
  • Seagate BarraCuda 1TB SATA III 3.5" HDD (extra storage)
  • Running Windows 10 Pro (version 1909)
If anyone has any clever ideas as to what could be going on, I'd be hugely grateful.

Thanks in advance!
 

Vic 40

Polypheme
Ambassador
Looks like drivers, but might be gpu, hard to say. Me myself do not run the latest from Nvidia. Think it gives some problems on my systems. I run 442.74 right now.

Don't know why you would want to limit performance of the gpu unless you get screen tearing since pushing out more fps than your monitor is good for. Even using Vsync gives some overhead since it forces the gpu to put out fps frame by frame instead of pushing out whatever it can.

Since you looked at the psu, which isn't the greatest choice, would it maybe help to power the gpu with two cables instead of one (=2 connectors) , maybe that would add stability. But i don't count on it and am not saying the psu is the culprit here. Just saying it might help with stability.
 
May 23, 2020
2
1
15
0
Update on my issue:

Shortly after making this post, the issue recurred whether VSYNC was turned on or not.

I thought about it, and reasoned that the only real cause of a sudden, unexpected, complete loss of power had to be an issue with the PSU.

As such, I replaced the PSU with a Corsair RM850X - it's basically a slightly beefier version of the one I had previously, and fully-modular rather than semi-modular. I'm not sure I really needed the extra wattage, but I figured it couldn't hurt!

Either way, everything seems to be running fine with the new PSU installed, so I guess the other unit must have been faulty.

It's all a bit annoying as I'd hoped to be able to get away with not replacing any components (and I got price-gouged for the new PSU due to short supply - I guess everyone's using the pandemic as an excuse to build a new PC!), but hopefully someone finds all this useful at some point down the line.
 
Reactions: King_V
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS