Need a little graphics card help here

mighteous

Distinguished
Nov 11, 2011
3
0
18,510
Hi everybody,

First of all, I only have a real basic knowledge of computers and their components, so forgive me if I sound funny here :)

I have a Dell E521. I had replaced the PSU to a 450W because I had an 8800gt installed. I paid somebody to install that card so I dont know how it worked.

Anyways, the 8800gt was replaced with an X1300 pro that came with the system, and recently I bought an ATI Radeon HD3850 off of ebay. I uninstalled the drivers for the x1300 and then plugged in the HD3850, but when I turned on the computer there was no video display. Looking inside the case, I could see that the fan on the GPU was spinning.

I'm not sure how to tell if my PSU is good enough to power the card. I also am not sure how to read the sticker on the PSU. Most threads I've read talk about 12v, so:

+12v1-14a-168w, +12v2-16a-192W, -12v-0.3a-3.6w

the label says Allied ATX 450 W switching power supply.

Given all this info, can anybody steer me in the direction I need to go? Is the power supply enough for the card? I thought an 8800 gt required more power than an hd3850 and the PSU was powering that just fine.

Appreciate any help here. Thanks.
 
Also make sure that you set the BIOS to run from the Add-In card not the Integrated VGA.
After you check that the Power connector is all in Place and hooked up properly, see if the num look still flashes when you press it, if it does so... check your monitor cable.
 

mighteous

Distinguished
Nov 11, 2011
3
0
18,510
Hey,

Yeah i plugged the power cable into the 3850, and BIOS is set up to use the add in card. The monitor cable is good also.

One thing I forgot to mention, the graphics card doesn't show up in device manager at all. It doesn't even get detected. Do you think maybe the card is dead?

What kind of video card would you guys recommend for an E521? It has a amd athlon 64 x2 dual core 4000+ 2.1 ghz processor and 2 gb ram. Im not looking to spend alot. Just want to be able to turn on the higher settings when I play Champions Online.

Thanks for your help, guys.