Need for Speed: Shift 2 Unleashed crashes when loading races

Pestilaence

Reputable
Jan 30, 2015
11
0
4,510
0
Hey guys,
I have the game through Steam, and it was working fine for a while. Suddenly, last night, the game crashed. I restarted it, but found that whenever I attempt to go into any of the races, the game crashes again. I'm not sure why, but I can go into the garage or car lot without an issue. I can let the game sit in any of the menu's or side areas without an issue, but as soon as I try to start a race, it crashes after about 3-4 seconds of reaching the loading screen.

I've tried lowering all of my graphical settings, changing refresh rates, uninstalling/ reinstalling Physx, and repairing C++. I have had no recent updates of any kind, whether that be random drivers, or for the game itself. I usually have EVGA Precision X up, to monitor the GPU, as well as A-Tuning to monitor the CPU, and nothing out of the ordinary happens during the time of the crash, on either end.

Judging by this, I'm assuming the issue is with Physx (even though I ran a fresh install of it), but can't prove it yet. My computer is more than powerful enough to run the game without issue. In fact, I had the game at pretty much max settings (minus the blur, because I like actually being able to see what's going on) for the entirety of the time that I've owned it, and have not had an issue prior to this.

I've looked into other reasons this could happen, and have not had any luck remedying the issue. I have also searched on here, but couldn't find an issue similar to this. Has anyone ran into this before? Maybe even with a different game?
 

Pestilaence

Reputable
Jan 30, 2015
11
0
4,510
0
I've already verified the file integrity, but will try to roll the drivers back. I may also uninstall/ reinstall the entire game, after backing up my profile of course.
 

ASK THE COMMUNITY