Question Need For Speed: Underground 2 won't start

Mar 18, 2019
12
0
10
0
Hey! i'm sorry, i'm pretty late with this and also sorry for my bad english. I got the nfs: underground 2 recently from my brother. It is legal copy, has both 2 discs, discs are fine, all that basic stuff. Setup works fine, i get everything installed normally. In the middle of the installation it asks me to put in disc num. 2, i do so. everything goes fine. then everything is installed and i try to run the game. the loading screen shows up (the one with the woman and 2 cars) and it stays there for about 5 seconds, then dissapears, and the screen goes black, shows desktop again, black again and then back to my desktop again, followed by message: "speed2.exe has stopped working". What should i do? I have tried everything; downloading patches, put the settings to run it in windows xp service pack 2 mode (as windows recommended), i tried run it as an administrator, i tried updating every driver that i think could effect such as my graphics card, cpu, audio card, motherboard, chipset, getting version 9.0c of directX as the game recommends, un- and reinstalling the game twice, basically everything. i simply don't get it. i tried to look on the internet but found nothing, and came here to ask if anyone knows how to fix this.

my system specs:
OS: Windows 7 64-bit home premium
Graphics card: ATI radeon hd 5450
CPU: AMD athlon x2 220 2.8gHz
RAM: 6gb
motherboard: foxconn 2aa9
chipset: AMD 780g
DirectX: 11/9.0c
Audio: AMD hdmi output (high definition audio)

if anyone can help, please tell me. i would appreciate that so much. thank you.
 
Mar 18, 2019
12
0
10
0
thanks for fast reply. in windows event viewer, i can see the errors but they don't have any information or error codes or anything. then i had only one dump file on my pc and it was too old to be dump file made by nfs:ug2. thanks anyway.
 

ASK THE COMMUNITY

TRENDING THREADS