Need help assigning my NFS server a static IP address

Aug 2, 2018
2
0
10
0
My computer max's out at 100 Mbps when connected through ethernet cable. My max speed with my plan is 150 Mbps through my ISP. So, I purchased a Plugable USB 3.0 Gigabit ethernet adapter which should allow me to take advantage of my maximum speed. However, once I run the ethernet to the plugable usb and plug that into a USB 3.0 slot its changing my NFS server's IP address which is messing with streaming movies, videos, etc....throughout the house. I set the server up to share media througout the house. When the ethernet cable is plugged directly into cpu the NFS server IP is 192.168.1.121 things stream fine and then I run the ethernet to the new pluggable usb it changes to 192.168.1.163. I would like to make the former IP address static if possible. The pluggable isn't even giving be the faster speeds yet but I'm trying to tackle 1 problem at a time. I know my set is more than capable of the speed increase since when I run a speed test on my phone or iPad I get speeds up to 170 Mbps. Is what I would like to do possible? This is the plugable USB that I am using https://plugable.com/products/usb3-e1000. My router is a Linksys WRT1200AC. Any assistace with this would be greatly appreciated. TIA
 
It makes no difference what the wireless does when you are using a ethernet cable. If it was say running 110mbps then you would suspect something else but when it is consistently under 100mbps...especially if you getting number around 94mbps ...then it means a port is only running at 100mbps. Most times this is due to a bad cable but it can be a port setting
 
It has a different mac address so is being assigned a different IP by the router. You can either set a static dhcp reservation in the router or you can manually set the ip in the pc.

Unless your PC is extremely old it will have gigabit ports. Your router also has gigabit ports so that means you likely have a bad ethernet cable. It could be the port settings on the pc, you want to be sure the speed is set to auto.

Now if you have a old pc with only 100mbps ports I suspect it is also so old it will have issue keeping up with the USB adapters. You really want a USB3 port, USB2 has a rated maximum of 480mbps and that is no overhead. Any machine that has a usb3 port will have gigabit ethenet ports already.
 
Aug 2, 2018
2
0
10
0
Hi,

Thanks for the quick response. My PC is about 5 years old. It does have the blue colored USB3 ports on it and thats where I inserted the pluggable. The wireless card in it only picks up 2.4Ghz. How do I adjust/set the port settings? I'll try another cable even though it's never topped 100Mbps in a speed test nor when I monitor download speeds.
 

ASK THE COMMUNITY

TRENDING THREADS