Need Help - asus a7n8x deluxe, getting sata to work


Aug 1, 2002
Hey folks, I tried searching but found only articles, not forum threads.

I know the A7n8x was pretty popular a few years back, I still have mine and am using winxp sp2, I was hoping someone could give me advice if they went through this as well.. I wanted to get a bigger HD than my current 40gb ide, but a HD that when I later upgraded my system, would still work - so a sata drive.

I'm having some real issues getting the sata to work with my board though, and I need some serious help.

Okay facts are:

1)floppy is working, floppy is good. I have the following sata files on my floppy: Si3112r system inf, Si3112r.mpd, SIISUPP.VXD, txtsetup.oem, Si3112r setup inf.

2) Bios is set to boot from sata/scsi, bios version is 1008.

3) Jumper is set to sata on

When I attempt to boot without the IDE HD connected, so I can do a fresh windows XP install, it lists no drive in the primary/secondary IDE HD spot on the post screen. After that, I hit F4 and go to the RAID/SATA option, here I briefly see the info on my SATA HD listed.

If any disks are in the drives, it asks me to remove media and then restart.

If no disks are in the drive, it begins searching DMI files, or some such thing - and never moves past that.

If I connect the IDE HD, and attempt to start up and then hit F4 to go to the raid screen, it will still boot from windows normally. I am unable to see the sata hd in my control panel then, or in the device manager.



Aug 18, 2007
I recently had this issue with the same board, and spent days sifting through tech forums with no luck. Then came a cross a post suggesting downloading the latest nvidia sil sata drivers and installing them prior to connecting the new drive.

Email me on and I'll send you the file as I have lost the link.

It has an automatic setup routine so no mucking around.

Worked for me straight away.