Need help!! Can't delete files/folders even though I am the owner/admin


Apr 3, 2013
I've searched around a bit and I can't seem to find a discussion about my particular problem.

I cannot delete files or folders from the c: drive, even though I am logged in as Admin with full control and I am also the owner of the folder.
When I go to delete the folder (not just one in particular, happens with any folder/file), I get the "Are you sure you want to move this folder to the Recycle Bin?" prompt and click "Yes".
Then comes the "You'll need to provide administrator permission to delete this folder" and I click Continue, then the progress window pops up showing "moving x number of files to recycle bin" or something like that and gets to 100%, but the folder and all the files remain.
I also cannot rename or move the folder to another location, but I never receive and access denied prompt or anything like that. I can also still access the files after trying to delete them so I know its not just a placeholder left behind.
They only pop up window I've found that shows there is a problem is when I open the Advance Security Settings for the folder and attempt to change Owner, when I click "Change" the window says "Can't open access control editor. the activation requires a display name to be present under the CLSID key."
I tried a quick Google search of that but I couldn't find anything about Windows 8 or something else helpful.
I will also add that I can delete files/folders in Safe Mode with no trouble, but I am more concerned with the cause of the problem than the files themselves.

I noticed my UAC is completely dysfunctional. I have exactly the same issue except I cant edit files on my secondary hard drives and some folders on my C drive.
Not sure if this was caused by a windows update which I also did today.

Exactly what is happening to me and I have additional symptoms:

• When I run "services.msc" I see this error all over the place: <Failed to Read Description. Error Code: 2 >

• My power options are non-existent/power configurations can't be found (red X).


Similar threads