Question Need help! Game crashes on launch!

Jan 27, 2020
8
0
10
0
Hi, I built my PC in August and its my first one. I had no problems whatsoever. But now recently, my Modern Warfare can no longer launch as well as Apex and simple rockets 2. It started when i tried downloading a Gamecube rom for dolphin emulator. So i thought i got a virus and i completely reset my PC and SSD. It took 3 hours to delete. I reinstalled windows 10 and Apex but it does the same thing. I get through the EA and respawn logos, left click "continue" and the game closes with no error message. Sometimes it freezes the entire pc where i have to reset it. I reinstalled all drivers and updates. I ran virus scan and it keeps saying everything is ok. It never had this problem before so i dont expect the drivers. I repaired EAC, reinstalled, all that over 10 times. Still cant play it. I have Ark, which crashed at first but now is playable. And i have Dayz which runs like butter. Ive been trying to figure this out for about 2 days now. Trying everything ive read on here and other forums. No luck anywhere. Please if you know what i should do, or should try please please help me.
ALSO, CPU GOES UP TO 100% DURING APEX LEGENDS LAUNCH!!!. So far after pc reset i only have apex, ark, and dayz downloaded. Cpu goes to 100% then it closes. My Cpu has NEVER been above 40%

System specs are:
GPU: Radeon RX 5700
CPU: Ryzen 7 3800x
PSU: Corsair RM850x
Motherboard: ASUS Prime pro X570
Cooling: Corsair H100i
Storage: Samsung evo 860 1TB
RAM: 2 8gb Corsair Vengence
 

Dcopymope

Prominent
BANNED
Aug 13, 2018
472
26
695
4
Hi, I built my PC in August and its my first one. I had no problems whatsoever. But now recently, my Modern Warfare can no longer launch as well as Apex and simple rockets 2. It started when i tried downloading a Gamecube rom for dolphin emulator. So i thought i got a virus and i completely reset my PC and SSD. It took 3 hours to delete. I reinstalled windows 10 and Apex but it does the same thing. I get through the EA and respawn logos, left click "continue" and the game closes with no error message. Sometimes it freezes the entire pc where i have to reset it. I reinstalled all drivers and updates. I ran virus scan and it keeps saying everything is ok. It never had this problem before so i dont expect the drivers. I repaired EAC, reinstalled, all that over 10 times. Still cant play it. I have Ark, which crashed at first but now is playable. And i have Dayz which runs like butter. Ive been trying to figure this out for about 2 days now. Trying everything ive read on here and other forums. No luck anywhere. Please if you know what i should do, or should try please please help me.
ALSO, CPU GOES UP TO 100% DURING APEX LEGENDS LAUNCH!!!. So far after pc reset i only have apex, ark, and dayz downloaded. Cpu goes to 100% then it closes. My Cpu has NEVER been above 40%

System specs are:
GPU: Radeon RX 5700
CPU: Ryzen 7 3800x
PSU: Corsair RM850x
Motherboard: ASUS Prime pro X570
Cooling: Corsair H100i
Storage: Samsung evo 860 1TB
RAM: 2 8gb Corsair Vengence
Unfortunately it could be a thousand different things causing this. What anti-virus program do you have installed? Even that can crash your games, did it to me until I uninstalled it.
 

Dcopymope

Prominent
BANNED
Aug 13, 2018
472
26
695
4
I just have the windows defender installed
Ok, if you can remember exactly when the crash happened, check out the event viewer screen, and scroll down to what was reported at the time it crashed. What does it say? Just type 'event viewer' in the search bar, go to 'administrative events', and scroll down to the logs that were reported at the time the crashes occurred.
 
Jan 27, 2020
8
0
10
0
Ok, if you can remember exactly when the crash happened, check out the event viewer screen, and scroll down to what was reported at the time it crashed. What does it say? Just type 'event viewer' in the search bar, go to 'administrative events', and scroll down to the logs that were reported at the time the crashes occurred.
Im going to launch apex and then look at the events. I have to download again
 
Jan 27, 2020
8
0
10
0
I got a bunch saying Performance power management features on processor 15 group 0 are disabled due to a firmware problem. Source Kernel processor power
 

ASK THE COMMUNITY

TRENDING THREADS