[SOLVED] need help in troubleshooting

Jan 12, 2022
4
0
10
hello, all I need help in troubleshooting my pc I narrowed down the problem to either the PSU or GPU. the pc runs fine on the iGPU but if I plug in the PCI-E power for the GPU it will only turn on for 10-15 sec and I hear a sound I think coming from the PSU like its tripping or something. after that, I have to unplug the pc from the outlet for it to turn on again. it's running stock no OC.

system spec:
GPU: Asus Strix rx 570 4gb
PSU: EVGA 450bv
Proc: AMD A8-7680
Ram: 8gb ram 2x4gb
HDD: WD Blue 1tb
SSD: Samsung 870evo 250gb
Mobo: MSI a68hm

Thanks.
 

punkncat

Champion
Ambassador
In a quick search, the 450BV is considered a decent choice only in the aspect of its value for a low power system. With the issue you are describing and particularly the noise coming from the unit, discontinue use and look for a higher quality 550 unit.
 
Jan 12, 2022
4
0
10
In a quick search, the 450BV is considered a decent choice only in the aspect of its value for a low power system. With the issue you are describing and particularly the noise coming from the unit, discontinue use and look for a higher quality 550 unit.
is it due to a faulty psu or lack of power? it used to run fine for almost 2years the problem is only recent
 

punkncat

Champion
Ambassador
If I were to take a guess based on the reported quality of the PSU, I would guess that it is faulty. I hate to send you chasing issues where the resolution is to throw money at it. It is the most obvious case, but in truth given the possible age of the 570, it could be at fault instead or even as well.

I would suggest that it might be worth your while to ask of a mom and pop PC shop around, if you have one. With that said, a new PSU of that level 'should' be about $60 or so...which I would wager is far cheaper than the troubleshoot at a shop.