Question Need Help Installing Windows 10 on Samsung SSD

Jan 17, 2021
4
0
10
0
I have been trying the past few days to upgrade my HDD to an SDD and it is proving to be very difficult. Right now I am trying to install Windows 10 onto the SSD through a usb stick. I am running an AsRock motherboard which has UFEI instead of BIOS(I may not be understanding everything here). Anyways, I boot through the flash drive and can open the Windows Installer. I have been doing a custom install where I delete all the partitions on the drive, click new, then click install. The install seems to be going smoothly until it says restarting in 5 seconds. My computer restarts and 1 of two things has been happening. 1.)black screen "Reboot and Select Proper Boot Device..." 2.)Starts the Windows Install Process over.

I don't know if this is the problem but it may be. I originally tried to install SSD without knowing anything and made it a "Basic Data Partition" Or at least that's what it says in Computer Management. I have been googling like a mad man to try and fix this but I am STUCK!

Here's some pictures that may help. View: https://imgur.com/a/4HvTUx0
 

stundrah

Reputable
Sep 24, 2017
20
0
4,520
1
If the install process starts over again, it might simply be because it tries to boot from the USB stick instead of your new Windows install. Once the Windows install files are copied to your SSD you can remove the USB drive before it reboots.
 
Jan 17, 2021
4
0
10
0
If the install process starts over again, it might simply be because it tries to boot from the USB stick instead of your new Windows install. Once the Windows install files are copied to your SSD you can remove the USB drive before it reboots.
I just tried and got the dreaded "Reboot and Select Proper Boot Device..." screen that I will be seeing in my nightmares tonight. Thanks for the suggestion though.
 
UEFI and Legacy are two types of BIOS interface. BIOS itself is just a chip. Legacy option is usually shown as CSM in the BIOS, disabling CSM puts BIOS in UEFI mode.
Try to disable it (better for W10) but before that reset CMOS to default factory settings. Disconnect all other drives until windows installation (hopefully) finishes.
When installation starts delete all the partitions, don't partition it yourself, windows will make all the partitions it needs.
Speaking of Windows, how did you get it to USB ? Is it latest version ?
Also helps if computer is connected to internet by wire and windows can download drivers if any are missing.
 
Jan 17, 2021
4
0
10
0
UEFI and Legacy are two types of BIOS interface. BIOS itself is just a chip. Legacy option is usually shown as CSM in the BIOS, disabling CSM puts BIOS in UEFI mode.
Try to disable it (better for W10) but before that reset CMOS to default factory settings. Disconnect all other drives until windows installation (hopefully) finishes.
When installation starts delete all the partitions, don't partition it yourself, windows will make all the partitions it needs.
Speaking of Windows, how did you get it to USB ? Is it latest version ?
Also helps if computer is connected to internet by wire and windows can download drivers if any are missing.
Okay so I figured out how to disable CSM. I'm not sure about CMOS defaults, but I can change my UFEI settings to default. The only drives I had connected are the SSD and the flash drive with windows ( I installed onto the 16gb drive yesterday using windows installation media). I tried the custom install where I delete all the partitions and just click start. And my computer is pluged into router via ethernet cable. I tried it and it got the same two results depending on if I take the stick out or not.
Could it be because I am using boot priory to make the usb drive the boot drive. I seen in a youtube tutorial some BIOS have boot override button which is different, but i dont see that on mine. So when i have tried this I make the UFEI Version of the USB Stick 1st Priority then the SSD 2nd. It shows up fine in the windows installer
 
Okay so I figured out how to disable CSM. I'm not sure about CMOS defaults, but I can change my UFEI settings to default. The only drives I had connected are the SSD and the flash drive with windows ( I installed onto the 16gb drive yesterday using windows installation media). I tried the custom install where I delete all the partitions and just click start. And my computer is pluged into router via ethernet cable. I tried it and it got the same two results depending on if I take the stick out or not.
Could it be because I am using boot priory to make the usb drive the boot drive. I seen in a youtube tutorial some BIOS have boot override button which is different, but i dont see that on mine. So when i have tried this I make the UFEI Version of the USB Stick 1st Priority then the SSD 2nd. It shows up fine in the windows installer
Most should have it by now, On my Asus MB it's F8 for fast boot device choosing, no matter which is set in BIOS. That should show only bootable drives. After a first restart BIOS starts first bootable device and that should be your disk, not USB or it will start setup all over again. With Windows, fist restart happens after all files for installation are already copied to the disk, after that you don't need USB dongle any more, you can take it out at that time, then only thing left is your disk.
 
Jan 17, 2021
4
0
10
0
Most should have it by now, On my Asus MB it's F8 for fast boot device choosing, no matter which is set in BIOS. That should show only bootable drives. After a first restart BIOS starts first bootable device and that should be your disk, not USB or it will start setup all over again. With Windows, fist restart happens after all files for installation are already copied to the disk, after that you don't need USB dongle any more, you can take it out at that time, then only thing left is your disk.
Okay thanks for the suggestion. I thought that was going to work however I was faced with Reboot and Select Proper boot device screen once again :(
 

ASK THE COMMUNITY

TRENDING THREADS