Question Need help - is everything plugged in correctly?

PCTerminator

Honorable
Oct 15, 2016
14
0
10,510
0
PC Parts: https://pcpartpicker.com/list/Wb7Yp2


Hey!

This is my very first 'own' build, basically all done by myself and after a bad experience years ago I never did anything on my hardware again until now. I hope I found the right sub-forum for this entry as well.

Please don't kill me or go for the 'read the manual', I did, watched videos and I am still scared <Mod Edit>.

Could someone do me a favor and tell me if they see a mistake with the cables I connected?



Mainboard:
View: https://i.imgur.com/kIx6HQL.png




A) Top left, CPU1 and CPU2, used the 8pins only, connecting them with P8/P4 below the PCIE1 slot. I didn't payed attention in which order the CPU 4pins were plugged into the top one as they were two seperated endings.

B) Top right, connected my Kraken's 3pin pump controller with the cpu_fan header. I've read I can do that or plug it into the AIO pump one near C, NZXT manual is saying either works, Motherboard says AIO, Internet says also both work (?).

C) The ATX cable is going straight into the PSU into the big MB slot and the smaller 8pin MB slot (unsure however:)

D) USB 3 connecting the front USB slots with my MB

E) Connected the rear fan with cha_fan1

F) A lot of small ones according to the MB manual, top left PLED+, beside that PLED -, then Power SW, below that the reset one.

G) cha_fan2, connected with the Corsair fan hub on the back, which has 2 splitters for front and side fans in slot 1 and 6 (cables were too short, an issue?)

H) The USB connection for the Kraken

I) Audio cable from the case



The additional USB from the case can't be connected with this MB (unfortunately, probably need an adapter?)



AIO:

Example Image

View: https://i.imgur.com/EC7Gjkj.png




- Connected the small fan cable with cpu_fan header Mainboard B)

- Connected the USB with Mainboard H)

- The 3 fans go right into the screen, so nothing done there (?)

- The RGB thing just hangs on the back of the case without a connection, like the one with '?'

- Connected with a PSU SATA cable that also connects with the the fan hub



Can cables just hanging around in the back of the case be an issue? Like I've had it in my older PCs, in this one, but never knew why that wouldn't be an issue. (see the AIO image reference '?')



The cables of the Z73 display are touching the RAM - issue? There's no space otherwise unfortunately.





GPU:
Example Image

View: https://i.imgur.com/xzhr1rI.png




Do I need to plug them into an order or anything?


PSU:
Example Image

View: https://i.imgur.com/7kJNQ73.png


A) & B) The GPU is connected with 3 8pins to the PSU, VGA1, VGA1, VGA2 (no specific order? I somehow killed a GPU years ago so that's the reason I am scared regarding current prices etc). VGA1 are both in PCIE1, VGA2 in PCIE2

C) & D) MB again with the big and smaller MB power connections

E) is connected with the Mainboard via a cable that has a CPU1/CPU2 label (see above, Mainboard A)

F) SATA cable that has several opportunities to plug things into and I have no clue how many things it can power. Currently has the AIO on it and the Fan hub, it's plugged into the bottom DRIVER one.



Fans:

Actual image

View: https://i.imgur.com/oI7puCP.jpg

View: https://i.imgur.com/G7g48ad.jpg




Fans of front, rear, and NZXT - does that configuration make sense?





Beyond thankful for everyone that could have a look and let me know if this works and I can set it up as my work would really need the additional power.



Thanks everyone!
 
Last edited by a moderator:

Lafong

Prominent
Dec 2, 2021
723
128
590
10
A suggestion:

Your post is several feet long with quite a few questions. The pictures don't help a lot.

Can you simplify things?

What happens when you try to fire it up?

Any signs of life, like fans spinning, lights flashing?

Maybe you've tried to start it up and failed? Or maybe you are afraid to try?
 
Dec 3, 2021
6
0
10
0
PC Parts: https://pcpartpicker.com/list/Wb7Yp2


Hey!

This is my very first 'own' build, basically all done by myself and after a bad experience years ago I never did anything on my hardware again until now. I hope I found the right sub-forum for this entry as well.

Please don't kill me or go for the 'read the manual', I did, watched videos and I am still scared <Mod Edit>.

Could someone do me a favor and tell me if they see a mistake with the cables I connected?



Mainboard:
View: https://i.imgur.com/kIx6HQL.png




A) Top left, CPU1 and CPU2, used the 8pins only, connecting them with P8/P4 below the PCIE1 slot. I didn't payed attention in which order the CPU 4pins were plugged into the top one as they were two seperated endings.

B) Top right, connected my Kraken's 3pin pump controller with the cpu_fan header. I've read I can do that or plug it into the AIO pump one near C, NZXT manual is saying either works, Motherboard says AIO, Internet says also both work (?).

C) The ATX cable is going straight into the PSU into the big MB slot and the smaller 8pin MB slot (unsure however:)

D) USB 3 connecting the front USB slots with my MB

E) Connected the rear fan with cha_fan1

F) A lot of small ones according to the MB manual, top left PLED+, beside that PLED -, then Power SW, below that the reset one.

G) cha_fan2, connected with the Corsair fan hub on the back, which has 2 splitters for front and side fans in slot 1 and 6 (cables were too short, an issue?)

H) The USB connection for the Kraken

I) Audio cable from the case



The additional USB from the case can't be connected with this MB (unfortunately, probably need an adapter?)



AIO:

Example Image

View: https://i.imgur.com/EC7Gjkj.png




- Connected the small fan cable with cpu_fan header Mainboard B)

- Connected the USB with Mainboard H)

- The 3 fans go right into the screen, so nothing done there (?)

- The RGB thing just hangs on the back of the case without a connection, like the one with '?'

- Connected with a PSU SATA cable that also connects with the the fan hub



Can cables just hanging around in the back of the case be an issue? Like I've had it in my older PCs, in this one, but never knew why that wouldn't be an issue. (see the AIO image reference '?')



The cables of the Z73 display are touching the RAM - issue? There's no space otherwise unfortunately.





GPU:
Example Image

View: https://i.imgur.com/xzhr1rI.png




Do I need to plug them into an order or anything?


PSU:
Example Image

View: https://i.imgur.com/7kJNQ73.png


A) & B) The GPU is connected with 3 8pins to the PSU, VGA1, VGA1, VGA2 (no specific order? I somehow killed a GPU years ago so that's the reason I am scared regarding current prices etc). VGA1 are both in PCIE1, VGA2 in PCIE2

C) & D) MB again with the big and smaller MB power connections

E) is connected with the Mainboard via a cable that has a CPU1/CPU2 label (see above, Mainboard A)

F) SATA cable that has several opportunities to plug things into and I have no clue how many things it can power. Currently has the AIO on it and the Fan hub, it's plugged into the bottom DRIVER one.



Fans:

Actual image

View: https://i.imgur.com/oI7puCP.jpg

View: https://i.imgur.com/G7g48ad.jpg




Fans of front, rear, and NZXT - does that configuration make sense?





Beyond thankful for everyone that could have a look and let me know if this works and I can set it up as my work would really need the additional power.



Thanks everyone!
PC Parts: https://pcpartpicker.com/list/Wb7Yp2


Hey!

This is my very first 'own' build, basically all done by myself and after a bad experience years ago I never did anything on my hardware again until now. I hope I found the right sub-forum for this entry as well.

Please don't kill me or go for the 'read the manual', I did, watched videos and I am still scared <Mod Edit>.

Could someone do me a favor and tell me if they see a mistake with the cables I connected?



Mainboard:
View: https://i.imgur.com/kIx6HQL.png




A) Top left, CPU1 and CPU2, used the 8pins only, connecting them with P8/P4 below the PCIE1 slot. I didn't payed attention in which order the CPU 4pins were plugged into the top one as they were two seperated endings.

B) Top right, connected my Kraken's 3pin pump controller with the cpu_fan header. I've read I can do that or plug it into the AIO pump one near C, NZXT manual is saying either works, Motherboard says AIO, Internet says also both work (?).

C) The ATX cable is going straight into the PSU into the big MB slot and the smaller 8pin MB slot (unsure however:)

D) USB 3 connecting the front USB slots with my MB

E) Connected the rear fan with cha_fan1

F) A lot of small ones according to the MB manual, top left PLED+, beside that PLED -, then Power SW, below that the reset one.

G) cha_fan2, connected with the Corsair fan hub on the back, which has 2 splitters for front and side fans in slot 1 and 6 (cables were too short, an issue?)

H) The USB connection for the Kraken

I) Audio cable from the case



The additional USB from the case can't be connected with this MB (unfortunately, probably need an adapter?)



AIO:

Example Image

View: https://i.imgur.com/EC7Gjkj.png




- Connected the small fan cable with cpu_fan header Mainboard B)

- Connected the USB with Mainboard H)

- The 3 fans go right into the screen, so nothing done there (?)

- The RGB thing just hangs on the back of the case without a connection, like the one with '?'

- Connected with a PSU SATA cable that also connects with the the fan hub



Can cables just hanging around in the back of the case be an issue? Like I've had it in my older PCs, in this one, but never knew why that wouldn't be an issue. (see the AIO image reference '?')



The cables of the Z73 display are touching the RAM - issue? There's no space otherwise unfortunately.





GPU:
Example Image

View: https://i.imgur.com/xzhr1rI.png




Do I need to plug them into an order or anything?


PSU:
Example Image

View: https://i.imgur.com/7kJNQ73.png


A) & B) The GPU is connected with 3 8pins to the PSU, VGA1, VGA1, VGA2 (no specific order? I somehow killed a GPU years ago so that's the reason I am scared regarding current prices etc). VGA1 are both in PCIE1, VGA2 in PCIE2

C) & D) MB again with the big and smaller MB power connections

E) is connected with the Mainboard via a cable that has a CPU1/CPU2 label (see above, Mainboard A)

F) SATA cable that has several opportunities to plug things into and I have no clue how many things it can power. Currently has the AIO on it and the Fan hub, it's plugged into the bottom DRIVER one.



Fans:

Actual image

View: https://i.imgur.com/oI7puCP.jpg

View: https://i.imgur.com/G7g48ad.jpg




Fans of front, rear, and NZXT - does that configuration make sense?





Beyond thankful for everyone that could have a look and let me know if this works and I can set it up as my work would really need the additional power.



Thanks everyone!
well just a few things and i am no expert but just finished my first build in 20 years
since i have the owners manuals on your board but not powers supply the cables in a. should be in the pcie 3 / mb (motherboard )ports on the power supply at least thats how all mine say to do it.
b. ok
c. ok
d. ok
e. this is perfect for rear /top exhaust fans
f. looks good but reset might be needed for fan hub?
now as far as the fans looks like you have 10 fans 3 top 3 side 3 front and 1 rear.
g. as far as side/front fans i have no experience with the side/front combo since i would think it would br counter productive. but i have not done a smoke test on this type of set up . but intake coming from side right across front intake i would imagine cause a vortex and actually reducing air flow. but that being said. i would have front fans on either the current fan header or in cpu option header(cpu 2)
i. ok
 
Dec 3, 2021
6
0
10
0
well just a few things and i am no expert but just finished my first build in 20 years
since i have the owners manuals on your board but not powers supply the cables in a. should be in the pcie 3 / mb (motherboard )ports on the power supply at least thats how all mine say to do it.
b. ok
c. ok
d. ok
e. this is perfect for rear /top exhaust fans
f. looks good but reset might be needed for fan hub?
now as far as the fans looks like you have 10 fans 3 top 3 side 3 front and 1 rear.
g. as far as side/front fans i have no experience with the side/front combo since i would think it would br counter productive. but i have not done a smoke test on this type of set up . but intake coming from side right across front intake i would imagine cause a vortex and actually reducing air flow. but that being said. i would have front fans on either the current fan header or in cpu option header(cpu 2)
i. ok
PC Parts: https://pcpartpicker.com/list/Wb7Yp2


Hey!

This is my very first 'own' build, basically all done by myself and after a bad experience years ago I never did anything on my hardware again until now. I hope I found the right sub-forum for this entry as well.

Please don't kill me or go for the 'read the manual', I did, watched videos and I am still scared <Mod Edit>.

Could someone do me a favor and tell me if they see a mistake with the cables I connected?



Mainboard:
View: https://i.imgur.com/kIx6HQL.png




A) Top left, CPU1 and CPU2, used the 8pins only, connecting them with P8/P4 below the PCIE1 slot. I didn't payed attention in which order the CPU 4pins were plugged into the top one as they were two seperated endings.

B) Top right, connected my Kraken's 3pin pump controller with the cpu_fan header. I've read I can do that or plug it into the AIO pump one near C, NZXT manual is saying either works, Motherboard says AIO, Internet says also both work (?).

C) The ATX cable is going straight into the PSU into the big MB slot and the smaller 8pin MB slot (unsure however:)

D) USB 3 connecting the front USB slots with my MB

E) Connected the rear fan with cha_fan1

F) A lot of small ones according to the MB manual, top left PLED+, beside that PLED -, then Power SW, below that the reset one.

G) cha_fan2, connected with the Corsair fan hub on the back, which has 2 splitters for front and side fans in slot 1 and 6 (cables were too short, an issue?)

H) The USB connection for the Kraken

I) Audio cable from the case



The additional USB from the case can't be connected with this MB (unfortunately, probably need an adapter?)



AIO:

Example Image

View: https://i.imgur.com/EC7Gjkj.png




- Connected the small fan cable with cpu_fan header Mainboard B)

- Connected the USB with Mainboard H)

- The 3 fans go right into the screen, so nothing done there (?)

- The RGB thing just hangs on the back of the case without a connection, like the one with '?'

- Connected with a PSU SATA cable that also connects with the the fan hub



Can cables just hanging around in the back of the case be an issue? Like I've had it in my older PCs, in this one, but never knew why that wouldn't be an issue. (see the AIO image reference '?')



The cables of the Z73 display are touching the RAM - issue? There's no space otherwise unfortunately.





GPU:
Example Image

View: https://i.imgur.com/xzhr1rI.png




Do I need to plug them into an order or anything?


PSU:
Example Image

View: https://i.imgur.com/7kJNQ73.png


A) & B) The GPU is connected with 3 8pins to the PSU, VGA1, VGA1, VGA2 (no specific order? I somehow killed a GPU years ago so that's the reason I am scared regarding current prices etc). VGA1 are both in PCIE1, VGA2 in PCIE2

C) & D) MB again with the big and smaller MB power connections

E) is connected with the Mainboard via a cable that has a CPU1/CPU2 label (see above, Mainboard A)

F) SATA cable that has several opportunities to plug things into and I have no clue how many things it can power. Currently has the AIO on it and the Fan hub, it's plugged into the bottom DRIVER one.



Fans:

Actual image

View: https://i.imgur.com/oI7puCP.jpg

View: https://i.imgur.com/G7g48ad.jpg




Fans of front, rear, and NZXT - does that configuration make sense?





Beyond thankful for everyone that could have a look and let me know if this works and I can set it up as my work would really need the additional power.



Thanks everyone!
now as for the aio
the ??? cable looks to be a 3 or 4 pin rgb header which you would plug into header 10 or 11 respectively. this is from the motherboard manual. page 1-2 and 1-3.
not sure if this will happen on your aio but the my corsair aio does not like sharing sata power with others. so you may want to give it its own sata power cable. other than that looks good.

not able to connect usb front panel ? what case do you have the usb 2 should connect right next to your h. for the aio. # 9 on your manual.
as far as cables hancing loose try and keep them flat and contained so they don't get pinched' but as long as no bare wires used cables can be just zip tied out of the way.
cable touching ram the heat should not be an issue but if the cables are put pressure on the ram i would try and reroute them.
your psu looks to have 10 pin connectors so if you have the cables to do it seeing as yo would have used 1 10 pin for mb. you should try and use pcie 1 port 1 and 2 ) assuming you are using 10p to 2x8p cables and a an 8p cable . and order has never mattered that i know of . your example build is close to my new ryzen 5950 build.

and back to th fan thing. my case is slightly smaller but i have a 1 x2 -3x1 setup with aio . 3 exhaust 1 rear in what would be your e ( rear thermal ) 2 top fans to exhaust air from top rear and 1 bottom fan intake using lower fan header for bottom to top air flow and help keep my gpu frosty. last i have aio front rad. fans in the cpu header.
hope this helps but like i said i am no expert . others i am sure could give better advise on air flow. and before the haters start yes my rad is upside down but pump is 4 inchses below the top of the radiator. so no air for me .
 
Last edited:
Dec 3, 2021
6
0
10
0
it would also help to post the case, cpu, gpu, psu and other components .

here is my build


Ryzen 9 5950x
Asus x570e gamer mobo
NVIDIA rtx 3060
64g ddr4 3600 18-22-22-42-64
2x Samsung 90 evo plus 2t v-nand
2x seagate 2.5 5t spinners (shucked external drives)
2x Toshiba X300 8TB
2x 16t Toshiba x300 spinners
Seasonic FOCUS Plus 850 Platinum
4x 32 inch Acer 2560x1440 240hz predator monitors
corsair H150i pro
2x 140 mm arctic p14 fans (top) 2k rpm
1 120mm p12 artic fan (rear)2k rpm
1 120 antec reverse flow 1700 rpm (bottom)
(don't laugh) Antec dp 502 flux

my case has the power supply and 4 big spinners on the bottom in a separate compartment and other 2 5t are mounted in the side cable management area. i have my psu exhausting out the bottom and bottom intake draws from a vent on side panel.
 

ASK THE COMMUNITY

TRENDING THREADS