[SOLVED] Need help, Low FPS despite High-End PC

Jul 17, 2019
4
1
15
0
Hello everyone,

I'm new to this community so this post might be in the wrong section. But I'm starting to get desperate for help. Recently I've looked at some Benchmarks on YouTube and noticed, that the fps they get is way better than mine, despite having the same GPU and CPU. That being said, my GPU is a GTX 1080 and my CPU is a i7 7700k which I overclocked to 4.5GHz. I see some people getting 90 FPS in GTA V but I struggle to keep up 70 and even dip in the low 50's. Same with the Witcher 3. I saw this guy get 100fps in Toussaint (The DLC) while I was still in White Orchard (starting area) and got about 70fps. Sorry, forgot to mention that I'm playing at 1080p with 144hz. So In my mind a GTX 1080 should have no problem staying at 90fps at 1080p. I will provide some further info and screenshots if I need to. Someone please help me as I'm not too great with PC's.

As for the specs:
CPU:
Intel Core i7-7700k Kaby Lake @ 4.50GHz (OC by me, 4.20 stock)
GPU: Nvidia GTX 1080
Drives: Crucial MX300 SATA M.2 525GB / Seagate Barracuda 2TB (2016)
Memory: Corsair Vengeance LPX DDR4 3000 C15 2x8GB
OS: Windows 10 Pro
Motherboard: Asus PRIME Z270-A
Monitor: 2x ViewSonic XG2402 @ 144Hz
PSU: Corsair HX1200i

temps in GTA V:
GPU:
61 C, 53%, 1671 MHz 47% 0.881 V
Mem: 3974 MB
CPU: 71 C, 57%, 4500 MHz 49.5 V
RAM: 8858 MB
D3D11: 55 FPS

EDIT:
Here's a link to my Benchmark score, maybe it'll help. (One I made with CPU-Z)
https://valid.x86.fr/jx71eu

EDIT 2:
I manually enabled XMP in my BIOS and I've noticed a big boost in FPS. Now I get around 90FPS. Just an FYI for everyone else with this problem.

(If any mods see this, I'm new and I don't know in which category to post this.)
 
Last edited:

ConanLock

Notable
May 22, 2019
1,057
212
1,190
31
According to the benchmark, your two sticks are only running in single channel mode, which could be causing your issue. Running RAM in dual channel effectively doubles the bandwidth from the RAM to the CPU. To get the RAM in dual channel, sticks should be in alternating slots - the second and last ones. So, when looking into these slots, it should go: empty RAM, empty, RAM.
In addition to this, your RAM isn't running at full speed. To run at full speed, you will need to enable XMP. Open the BIOS, and make sure you are in Advanced Mode. Now, go to the Ai Tweaker menu, and set Ai Overclock Tuner to X.M.P. Save what you have done.
After doing both of these, your FPS should be up to how you want.
 
Reactions: grimess
Jul 17, 2019
4
1
15
0
According to the benchmark, your two sticks are only running in single channel mode, which could be causing your issue. Running RAM in dual channel effectively doubles the bandwidth from the RAM to the CPU. To get the RAM in dual channel, sticks should be in alternating slots - the second and last ones. So, when looking into these slots, it should go: empty RAM, empty, RAM.
In addition to this, your RAM isn't running at full speed. To run at full speed, you will need to enable XMP. Open the BIOS, and make sure you are in Advanced Mode. Now, go to the Ai Tweaker menu, and set Ai Overclock Tuner to X.M.P. Save what you have done.
After doing both of these, your FPS should be up to how you want.
Yeah, I enabled XMP and seen a big boost in FPS. I'm gonna move the Sticks now and hope it works nicely.
Thanks in advance.
 
Reactions: ConanLock
Jul 17, 2019
4
1
15
0
According to the benchmark, your two sticks are only running in single channel mode, which could be causing your issue. Running RAM in dual channel effectively doubles the bandwidth from the RAM to the CPU. To get the RAM in dual channel, sticks should be in alternating slots - the second and last ones. So, when looking into these slots, it should go: empty RAM, empty, RAM.
In addition to this, your RAM isn't running at full speed. To run at full speed, you will need to enable XMP. Open the BIOS, and make sure you are in Advanced Mode. Now, go to the Ai Tweaker menu, and set Ai Overclock Tuner to X.M.P. Save what you have done.
After doing both of these, your FPS should be up to how you want.
I’ve stumbled across another problem. This one is way worse and due to me being a complete idiot. I tried changing the sticks of ram into the different slots so I’d switch from Single Channel to Double Channel. I tried A1, B1 and A2, B2. The thing is, my PC was working just fine before. Now I changed something and my PC won’t turn on. It doesn’t “recognize” the RAM regardless of where I put it. I also get this yellow-ish light next to it. I’ve read that it has something to do with the RAM and it would be the only logical thing since I’ve only tampered with it and nothing else. Now my PC turns on its fans etc. but my keyboard, mouse and my monitors don’t get any power or signal. The yellow light comes on and then my pc just restarts itself. Did I break the Ram or something? Please help me as I cannot do anything on my PC and I’m writing this on my Phone.
 

Groveling_Wyrm

Distinguished
Dec 11, 2002
1,676
26
20,190
122
I’ve stumbled across another problem. This one is way worse and due to me being a complete idiot. I tried changing the sticks of ram into the different slots so I’d switch from Single Channel to Double Channel. I tried A1, B1 and A2, B2. The thing is, my PC was working just fine before. Now I changed something and my PC won’t turn on. It doesn’t “recognize” the RAM regardless of where I put it. I also get this yellow-ish light next to it. I’ve read that it has something to do with the RAM and it would be the only logical thing since I’ve only tampered with it and nothing else. Now my PC turns on its fans etc. but my keyboard, mouse and my monitors don’t get any power or signal. The yellow light comes on and then my pc just restarts itself. Did I break the Ram or something? Please help me as I cannot do anything on my PC and I’m writing this on my Phone.
Ensure that your RAM sticks are fully seated in the slots. Visually check them, thoroughly.
 
Reactions: grimess

ConanLock

Notable
May 22, 2019
1,057
212
1,190
31
• Unplug the PC from mains.
• Take the CMOS battery (round silver thing) out.
• Hold power button down for around 10 seconds.
•Make sure RAM is correctly inserted. Open both the top and bottom lock of the slot you want to insert. Then, push the RAM in until the slots lock themselves.
• Put CMOS battery back in.
•Plug PC back in.
Now it should work. However, you will have to set the BIOS up again. This includes enabling XMP, setting time and date etc.
 
Jul 17, 2019
4
1
15
0
Thank you all for your replies. After finding the solution I can't help but feel absolutely idiotic. Turns out, I just had to apply a bit more force to insert the RAM in it's position. I've spent about 4-5 hours trying to figure it out. Again, sorry for my incompetence and I hope others can benefit off of my stupidity.
 

DSzymborski

Glorious
Moderator
Thank you all for your replies. After finding the solution I can't help but feel absolutely idiotic. Turns out, I just had to apply a bit more force to insert the RAM in it's position. I've spent about 4-5 hours trying to figure it out. Again, sorry for my incompetence and I hope others can benefit off of my stupidity.
Don't feel bad. Think about it this way: if you had done a better job inserting the RAM and then had problems, you might be shelling out money to replace hardware instead!

And we've all messed up. I once breadboarded an entire build before checking to see if the power cord was still firmly in the PSU's outlet.
 

ASK THE COMMUNITY

TRENDING THREADS