Question Need Help ! Major GameDVR Memory Leak Issue.

mohitakundi

Reputable
Mar 19, 2015
141
0
4,710
18
Specs : i3 5010u, 8GB RAM, 1TB HDD, Geforce 930m

In WIndows 10 1803, there used to be no issues. It used to work perfectly. I even recorded 1Hrs+ clips of my gameplay.

But now, in 1809 and now updated to 1903, there is a major memory leak issue. within a few mins, RAM usage goes from 29% to 98% and then crashes completely.

It is as if it's recording gameplay directly to RAM for some stupid reason

All settings a low, 30fps capped recording, audio at 128kbps. Background Recording is also off

Here's a reference video: Watch at 2x speed

Game DVR Memory Issue
You can see it rapidly climb to 90% and fall back to 26% after recording ends.
 

Colif

Win 10 Master
Moderator
memory leaks don't normally give the ram back, its more likely that it is using that ram to store the data as its much faster to use that than to write direct to drive. Having said that, it should start writing at some stage and not just crash

I see Microsoft weren't any help - https://answers.microsoft.com/en-us/windows/forum/all/absolutely-ridiculous-ram-usage-by-game-dvr-in/09e35b27-561b-4451-92f7-56759b5be997

Have you updated drivers on PC? most memory leaks are driver related but then those don't normally give the ram back after, they just keep wanting more.

See if this helps or shows any light on the situation
Download Process explorer and run it as admin (it comes from Microsoft so its safe)

the default view is tree structure meaning like your task manager screen, it will show what processes are under each service, but unlike task manager, it shows the ram usage of each part so you can see what is eating your ram

Private bytes = actual ram usage
Working set = Ram + page file usage

This page shows what all the colours and headings mean, link at bottom of it shows how to use it to find problems. You can right click headers and run an av scan from within the program.
 

mohitakundi

Reputable
Mar 19, 2015
141
0
4,710
18
I am on latest driver but i have tried older drivers as well. I don't think its a driver issue, cause the primary fault is that its writing directly to ram and not the disk(which it should at some point)
I tried OBS and it works fine, but sometimes fails to detect games or sometimes records audio only with a Black screen, but those are OBS issues.

Also, i tried just recording Task Manager by listing it as a "game" and it still kept eating memory till it froze to death
 

Colif

Win 10 Master
Moderator
Its bad when the only fix advised is not use it. Another is to buy more ram as then the problem won't happen as fast.

How big is your page file? Have you adjusted it at all? your page file usage with 6gb of ram in use is less than mine is at idle, so it seems it doesn't dump it to page file, it uses ram to store it all until the PC runs out and crashes... well done Microsoft.

hdd usage of that service isn't very big, even when its using 5.2gb of ram, it only goes to 0.6mb/s. Usage only increases once video is finished and it starts writing everything to hdd.

I found your post from April on Toms as well as Reddit, you could ask on https://www.tenforums.com/ as well as they might have another answer.

Have you tried a clean install? it could just be a glitch and reinstalling win 10 might fix it. You wasted several months already
 
Last edited:

mohitakundi

Reputable
Mar 19, 2015
141
0
4,710
18
Its bad when the only fix advised is not use it. Another is to buy more ram as then the problem won't happen as fast.

How big is your page file? Have you adjusted it at all? your page file usage with 6gb of ram in use is less than mine is at idle, so it seems it doesn't dump it to page file, it uses ram to store it all until the PC runs out and crashes... well done Microsoft.

hdd usage of that service isn't very big, even when its using 5.2gb of ram, it only goes to 0.6mb/s. Usage only increases once video is finished and it starts writing everything to hdd.

I found your post from April on Toms as well as Reddit, you could ask on https://www.tenforums.com/ as well as they might have another answer.

Have you tried a clean install? it could just be a glitch and reinstalling win 10 might fix it. You wasted several months already
Yes, I did try a clean install when I upgraded to 1809. Literally wiped the entire drive.
I'm trying not to do that again since it's a Crazy Huge headache downloading/installing each and every game and program I had before. Expecially X-Plane 10 Global !

I'll try tenforums but if nothing helps, i guess i have no option but to wipe it all again...
 

Colif

Win 10 Master
Moderator
you might be better using some other software instead as it seems they changed something about how it works in 1809.

I couldn't find anyone else with same issues. Just your posts. So it is strange its only happening to you.
 

ASK THE COMMUNITY

TRENDING THREADS