Need help: monitor losing signal during games

Jan 30, 2019
3
0
10
Best answers
0
Getting pretty desperate about this issue right now. Every time I play a game, within minutes to a half hour, the monitor turns black and loses signal and the sound cuts out either right away or after a minute or so. No blue screen and I have to hard reset the comp to get signal back. I'm using a 980ti and a 144hz1440p gsync monitor. Here are the facts so far as I've tried to figure out what's going :
-Only happens with games- I can watch/edit videos or use the comp for hours without ever having the issue
-when I used the onboard GPU with an old 720p hdmi tv, no issue
-when I used the 980ti with the same tv, no issue (my monitor is display port only and I don't have another discrete GPU to try)
-tried updating gpu and mobo drivers- no luck. Also tried reformating the comp completely and reinstalling windows- issue occurs with very first game I play. So definitely a hardware issue.
-since it didn't happen with the old TV, up tried turning off gsync in case the controller in the monitor was the issue- no luck.
-whole comp is connected to a cyber power sine wave ape and no changes were made to the hardware recently

Specs are:
Gigabyte g1 gaming z170x mobo
I7 6700k cpu
Evga 980ti acx2.0
32 GB gskill ddr3000
1Tb sandisk ssd
750Watt evga platinum psu
Acer 270hu bprz monitor

Frustratingly, I built the comp three years and two months ago so the warranties basically all just ended. So I'm trying to figure which part is the issue (top theory is gpu but psu and monitor aren't ruled out) before I order a replacement.

Thanks
 

Raerayu

Reputable
Nov 26, 2015
72
1
4,535
Best answers
0
Try testing a DVI instead of a display port, also good NVIDIA Display Port Drivers and download the newest ones.
 
Jan 30, 2019
3
0
10
Best answers
0


No luck with the Display Port firmware update. Also tried installing monitor drivers from Acer to no avail. Dont have a monitor that can use DVI unfortunately.
 

ASK THE COMMUNITY

TRENDING THREADS