Need help! Mysterious CPU usage 100%

pra300

Honorable
Dec 13, 2012
7
0
10,510
0
So, my CPU Usage is always 100% & I am scratching my head to figure out who's the culprit...

Interesting part,
I did notice it few days ago, I was checking my CPU temps using RealTemp and CoreTemp.
Both programs showed Temps ~65c, but CPU Load is always @100%
The moment I open Task Manager, CPU Load comes down to 0-2% and CPU temps back to usual 36-41c. :heink:
When I close Task Manager, CPU load goes to 100% and temps as high as mentioned above.
I experimented it by using Process Explorer Program, same things happens as Task Manager, I can't find which process is actually using most resources.
Only thing I can tell that svchost.exe is using most resources, at startup of task manager I noticed svchost.exe shows immediate reduction in CPU usage and memory usage. It happens in less than 2 seconds.
I must keep either Task Manager or Process Explorer program open to have CPU usage under control for the time being :pt1cable:

Solutions I tried:

I use Avira Free AV, recently I got Malwarebyte's AnitMalware Pro.
Did full scan with both, nothing was detected.
I Used Anti-rootkit utilities TDSSKiller and Windows Defender Offline. Both reported no threat. :sweat:

---
Windows 7 Ultimate x64
4GB RAM
 

hammereditor

Honorable
Nov 27, 2012
121
0
10,710
6



If your CPU does not appear to perform slowly when you use applications, then the CPU/Windows simply can't report its usage properly. The thing you said about it going down to 2% is making me suspect this.
 

pra300

Honorable
Dec 13, 2012
7
0
10,510
0


I did it last month, There is no issue with CPU temps. It just something is pushing my CPU usage to 100% :(
 
Didn't we have a thread here last week when someone had the same EXACT problem? Didn't it turn out to be a virus that was deactivating when it saw Task Manager start up?

Not saying thats the case here, but this sounds awfully like that case...
 

pra300

Honorable
Dec 13, 2012
7
0
10,510
0



I took this screenshot when task manager was closed

http://lookpic.com/O/i2/820/4KY2eW6C.jpeg

----

this one when task manager is started again.

http://lookpic.com/O/i2/969/krU9nB4s.jpeg


====

there is no suspicious activity in the task manager except svchost.exe (I explained in the first post), AV/Antimalware doesn't detect anything either!
 

pra300

Honorable
Dec 13, 2012
7
0
10,510
0


I suspect there is a virus, the solutions I tried did no good. what would you recommend?
 

pra300

Honorable
Dec 13, 2012
7
0
10,510
0
Hello everyone,
After spending hours trying to fix it I finally found the culprit!

I installed Norton 360 30-Day trial. Like any other solutions Norton found no threat.
Fortunately its performace monitor found a process that was consuming all CPU resources!
It turned out to be a trojan, it disguised as 'igfxupdate.exe' which acts as a windows service & hides itself from task manager and other performance monitoring programs.

All I had to do is to disable the service and delete its source:

1. Go to windows services
2. Disable the service "Search Indexer"
3. Restart PC
4. Open windows folder, search for igfxupdate
5. delete

Hope it will help other people. :D
 

Similar threads


TRENDING THREADS