[SOLVED] need help on cpu clock issues

Sep 16, 2021
4
0
10
0
hi,
not too good with computer stuff, but i've been trying to run multiple instances of LD player and after awhile my laptop gets overheated and crashes. so i'm trying to limit/lower down my CPU clock speed.
i've toggled with the power plan with no solutions.
i think the issue lies with the minimum processor state in the power plan:
at 100% my CPU clock speed is stuck at 3992mhz
at any value between 1-99% my CPU clock speed is stuck at 1697mhz (almost cut by half) and doesn't increase no matter how many processes i'm running, and it's too slow and laggy
any way to get a speed somewhere in between?
the maximum processor state doesnt seem to affect my clock speed
My CPU is AMD Ryzen 5 4600H on Huawei Matebook 14, laptop is new, just bought few days back, drivers and everything updated. BIOS has nothing related to CPU Speed to be altered.

I'm using NZXT CAM to get the figures
 

keith12

Illustrious
Hey there,

Try install/overwrite the power plans from here: Windows 10: How to restore the ultimate power plan and improve performance - TechRepublic - Sometimes when changing the min cpu state, it doesn't work to allow the CPU to clock up/down. Could be a bug or something. Try the power saver plan, and see if that changes it.

Also, look in your bios, and see if you have an option to enable/disable 'C States' and try with it on or off. Report back.

Also, check your bios is up to date, as this can also cause this issue.
 
The way Ryzen works doesn't seem compatible with the "Processor state" setting from my experience. Tweaking with it will make the CPU either pitter around at minimum clock speeds or allow it to clock however it wants up to the boost speed.

While I haven't used this myself, this looks like it could help: https://www.reddit.com/r/Amd/comments/anbl95 View: https://www.reddit.com/r/Amd/comments/anbl95/ryzen_master_for_mobile_ryzen_modify/

EDIT: Looks like Tom's Hardware may have covered it or a similar tool: https://www.tomshardware.com/news/ryzen-controller-software-amd-ryzen-laptop
 
Sep 16, 2021
4
0
10
0
Hey there,

Try install/overwrite the power plans from here: Windows 10: How to restore the ultimate power plan and improve performance - TechRepublic - Sometimes when changing the min cpu state, it doesn't work to allow the CPU to clock up/down. Could be a bug or something. Try the power saver plan, and see if that changes it.

Also, look in your bios, and see if you have an option to enable/disable 'C States' and try with it on or off. Report back.

Also, check your bios is up to date, as this can also cause this issue.
hi,

i've tried this method previously, and also tried with Ryzen's power plans and it doesn't work.

my BIOS:
https://drive.google.com/file/d/1vSVOZLoNaWE4TA7xKg4Nac_PXiiXXGrj/view?usp=sharing

https://drive.google.com/file/d/1NYDPEHkeQk5dqIJ1jDD7X6Z-VyN1-kHH/view?usp=sharing
 

keith12

Illustrious
Hey there,

So, first things first. Your bios is out of date. This could very well be the issue, as bios updates can fix hardware related issue. The newest Bios for your system is version 1.16. So download that and follow instructions to install, and report back when complete.
 
Sep 16, 2021
4
0
10
0
Last edited:

keith12

Illustrious
Oh. In your first pc of bios, it says it's running 1.06! Are you sure 1.06 is installed? Even the date doesn't match up. Your current bios is dated 25022021, and the newest update is 09082021, IIRC.
 

ASK THE COMMUNITY

TRENDING THREADS