Question Need Help! PC wont load OS with new 3090

Jan 27, 2023
I recently bought a second hand rtx 3090 gaming x trio to replace my old gtx 970. After installing it the pc booted fine and i could load the uefi, but when trying to load windows i got recovery screen after a few seconds. The GPU worked fine in the PC of the seller (i dont know specs). I tried both with 3 seperate pcie power cables and with 1 daisy chained. After reinstalling the 970 the problem persisted the first time i started the pc but the second time worked fine. Could this indicate my PSU or MoBo is fried? I don't have a second system to test the card with so im thinking about ordering a 1000w PSU to test if thats the problem (current one is 850).
Sytems specs:
x470 taichi ultimate
r7 2700x
64gb 3200mhz ram
rm 850x psu.


Retired Mod
First thing to do is make sure you have the MOST recent stable (Not Beta) motherboard BIOS version installed. If you do, or after you do, perform a hard reset of the BIOS to reset the hardware tables. Often this is the only solution that is required. Not always to be sure, but often enough that since it costs nothing to do it, it's always worth a try first. (Or second, if you need to first update the BIOS which generally has an even higher probability of resolving such issues with newer graphics card architectures)

BIOS Hard Reset procedure

Power off the unit, switch the PSU off and unplug the PSU cord from either the wall or the power supply.

Remove the motherboard CMOS battery for about three to five minutes. In some cases it may be necessary to remove the graphics card to access the CMOS battery.

During that five minutes while the CMOS battery is out of the motherboard, press the power button on the case, continuously, for 15-30 seconds, in order to deplete any residual charge that might be present in the CMOS circuit. After the five minutes is up, reinstall the CMOS battery making sure to insert it with the correct side up just as it came out.

If you had to remove the graphics card you can now reinstall it, but remember to reconnect your power cables if there were any attached to it as well as your display cable.

Now, plug the power supply cable back in, switch the PSU back on and power up the system. It should display the POST screen and the options to enter CMOS/BIOS setup. Enter the bios setup program and reconfigure the boot settings for either the Windows boot manager or for legacy systems, the drive your OS is installed on if necessary.

Save settings and exit. If the system will POST and boot then you can move forward from there including going back into the bios and configuring any other custom settings you may need to configure such as Memory XMP, A-XMP or D.O.C.P profile settings, custom fan profile settings or other specific settings you may have previously had configured that were wiped out by resetting the CMOS.

In some cases it may be necessary when you go into the BIOS after a reset, to load the Optimal default or Default values and then save settings, to actually get the BIOS to fully reset and force recreation of the hardware tables.

If that does not resolve the problem, the next step would be to put the GTX 970 back in and then do a clean install of the Nvidia drivers using the DDU.

It's also a good idea at this time, while you have the system working and in Windows, to visit the product page for your motherboard (Or in your case the AMD website for your chipset drivers) and make sure you have the latest chipset drivers, network adapter and also any wireless or bluetooth drivers as well. Any or all of these can sometimes conflict with each other so it's always a good idea to periodically make sure you are on the most recent versions. Afterwards, power off, flip the switch off on the PSU and swap the graphics cards back to the newer card and see if the issue resolves itself.

Your RM850x should be more than enough for that graphics card unless it's getting pretty long in the tooth and has developed some problems.
Jan 27, 2023
Thank you for your detailed answer. I tried everything you suggested but nothing seemed to resolve the issue. In the I found out one NVMe ssd was inserted only halfway in its slot. After that everything seems to work fine.