Need help please.

Oct 9, 2018
18
0
10
0
Hello, Short story. I have Asus h110m-k motherboard. I have installed my mobo drivers from here: https://www.asus.com/us/Motherboards/H110M-K/HelpDesk_Download/ I installed everything except ALsuite 3, Sound ( because it already works fine), I restarted my computer, went to device manager, and it said that Intel(R) 100 Series/C230 Series Chipset Family PMC - A121, Intel(R) 100 Series/C230 Series Chipset Family SMBus - A123, legacy device, system timer and Programmable interrupt controller Drivers were not installed. I don't know what to do, there are no exclamation mark next to it, when I click update drivers trough device manager it says that latest drivers are already installed. Do I really need those drivers ? Any solutions ? I read that some people had the same problem and someone told them to download this: https://downloadcenter.intel.com/download/20775/Intel-Chipset-Device-Software-INF-Update-Utility . when i ran this program it told me that I already have latest drivers and asked me if I want to downgrade. Don't know what to do, searched the whole internet.


 

drawingpin

Reputable
Dec 5, 2016
88
3
4,665
5
Personally I'd raise a help desk ticket with ASUS. I had memory issues earlier this year with my Gigabyte mobo. I raised a ticket with them and they were very helpful,

Jim.
 

drawingpin

Reputable
Dec 5, 2016
88
3
4,665
5


I think so. I don't know the ASUS site very well, but I'm sure there'll be a contact support link on there. Just make sure when raising your ticket you list your full including the MOBO version and the full background of what has happened. They may ask you to roll back your installed driver to the windows default. Hopefully they'll give you detailed instructions on what to do,

Jim.
 
Oct 9, 2018
18
0
10
0
I guess I can say that my system works well? Well, sometimes when I am watching Youtube the video lags for a sec, maybe this is because of web browser, I'm still using Microsoft edge ( I know I know). Steam sometimes lags for a couple of seconds. If I open start menu, only half of it shows for a sec, than the other half appears, sometimes when I turn on my computer my game icons have a square around them, games lag for example if I am playing CS:GO competitive, while waiting for players to join I get small lags again only for a sec, then very rarely it happens when I'm in the middle of the game. I don't know if these things that I said is had to do with my system or drivers, but atleast I think I shouldn't get lags in CS:GO with My specs:Nvidia GeForce gtx 1050 ti 4gb, 8gb ram, i5 7400.
 

mgallo848

Commendable
Apr 4, 2018
1,551
35
1,790
149
Even though the generic Windows drivers work for audio I would install them anyway. I believe the AI suite can also detect what drivers/ chipsets are missing and install those for you also. Doesn't hurt to try them.
 
Oct 9, 2018
18
0
10
0
For sound I agree, but for Alsuite hahaha, it does hurt, the reason I didn't install Alsuite because it has like 4 installation programs and I don't know which one is the right one, so I decided to read if I really need it, some people said that it isn't really necessary.
 

ASK THE COMMUNITY

TRENDING THREADS