Question Need help with a Ryzen 7 2700

Feb 15, 2020
2
0
10
0
Hello, i recently got a ryzen 7 2700 (stock) paired with a b450 aorus elite and 16gb gskill at 3000mhz, updated bios to latest version ( f51 ), also updated chipset (2.01.15.2138) and windows, and made sure that xmp is enabled.

My problem is that when im using the amd balanced power plan with a minimum processor state at 40/20/5% (it doesnt matter) cpu does not underclock down to 1.5ghz. Instead stays at ~3.2-3.5ghz and 1.085- 1.25v, with the 3.5ghz beeing the single core boost while idle ( or even using cinebench single core bench ). Same results with the windows balanced power plan.

But if i change to the high performance power plan, and set the minimum down to 20% then the cpu will downclock down to 1.5ghz and 0.89v, but it will constantly boost while idle up to 4.1ghz causing voltage to fluctuate between 0.89v to almost 1.44v, and tempature will also fluctuate from ~30c to 40+ every couple seconds causing AIO fans to ramp up all the time.

Now if i set the minimum processor state at 100% while using high performance plan, the single core boost drops to 3.5ghz again and all core to ~3.2 while idle.

Already tried to reinstall chipset drives and load optimize defaults with no luck, any help on to whats going on?
 
Last edited:

Mr.Spock

Prominent
Dec 8, 2019
568
61
590
48
You misunderstand what that does - that forces all cores to be active and of course you lose Turbo Boost.
Turbo boost is generally available when 1 or 2 cores are active and the others under light/no load.

Now if i set the minimum processor state at 100% while using high performance plan, the single core boost drops to 3.5ghz again and all core to ~3.2 while idle.
 
Feb 15, 2020
2
0
10
0
My bad, forgot to mention that the single core boost on high performance plan comes after running cinebench.
Using high performance should force all cores to run at the advertised 3.4ghz constatly, right? ( im getting 3.342mhz all cores )
Does also c state or amd cool n quet have any effect over the high perf. plan? because even with minimum / maximum processor state at 100% and idle cpu, it still boost to 4.1 constantly and voltage fluctuates between 1.087v and 1.425v, is that normal?

Also sorry for all the questions, im new to pc building and super confused on to whats going on, just trying to narrow down the performance issues that i have.
 

Mr.Spock

Prominent
Dec 8, 2019
568
61
590
48
actually it forces the cores to run 3.2GHz - reducing your chances of getting Turbo Boost since the "idle" cores would run at 100%. Max Turbo burst on 1-core is 4.1GHz btw.

C-state and Cool'n'quiet can work with the high performance plan. They interfere once you over clock (which is not the case here). Just load optimized defaults, save and exit. Make sure XMP is on and you should hit 4.1 when only a single core is in use.
 

ASK THE COMMUNITY

TRENDING THREADS