Aug 26, 2021
12
0
10
0
Hello everyone, I am a computer technician and a streamer from Lebanon trying to make some extra money through streaming due to the financial crisis of my country
So I've made a pc 2 years ago
Amd Ryzen 7 2700
16GB RAMs Apacer Panther 3000Mhz DDR4
Zotac GeForce GTX 1080 AMP Extreme Edition 8GB
Motherboard Asus Prime B450M-K
So I had 2 problems 1st my GPU never loaded more than 45% when I was playing rust and I was like it might be caused by my Power Supply so I changed the Power Supply lately with a Thermaltake 650W but didnt work out so I was like its okay as long as it lets me play and stream
After that started to have weird things happening, My PC sometimes turns on completely Normal with the orange LED on board blinking
And sometimes it never turns on while the motherboard's orange LED Stable not blinking so I thought it might be anything like my processor or something about the rams but nothing have worked out for me
I thought it might be the power button so tried to turn it on through a screw driver but it never worked out
So I left the pc for like about 5-6 hrs and went to work and once I came back clicked the power button it turned on nornally but today it didnt turn on
So I tried to remove the cmos battery for like 10 minutes and tried again but didnt work
I am actually frustrated I don't really know what in the blue hell is happening to my mobo
Any ideas ?
 
Hello everyone, I am a computer technician and a streamer from Lebanon trying to make some extra money through streaming due to the financial crisis of my country
So I've made a pc 2 years ago
Amd Ryzen 7 2700
16GB RAMs Apacer Panther 3000Mhz DDR4
Zotac GeForce GTX 1080 AMP Extreme Edition 8GB
Motherboard Asus Prime B450M-K
So I had 2 problems 1st my GPU never loaded more than 45% when I was playing rust and I was like it might be caused by my Power Supply so I changed the Power Supply lately with a Thermaltake 650W but didnt work out so I was like its okay as long as it lets me play and stream
After that started to have weird things happening, My PC sometimes turns on completely Normal with the orange LED on board blinking
And sometimes it never turns on while the motherboard's orange LED Stable not blinking so I thought it might be anything like my processor or something about the rams but nothing have worked out for me
I thought it might be the power button so tried to turn it on through a screw driver but it never worked out
So I left the pc for like about 5-6 hrs and went to work and once I came back clicked the power button it turned on nornally but today it didnt turn on
So I tried to remove the cmos battery for like 10 minutes and tried again but didnt work
I am actually frustrated I don't really know what in the blue hell is happening to my mobo
Any ideas ?
Try These if you could boot to windows:
  • Uninstall GPU Driver Using DDU
  • Uninstall all the processors in device manager like this, then boot up to bios:


Do it all without internet connection, download all the files needed first.
 
Aug 26, 2021
12
0
10
0
Aug 26, 2021
12
0
10
0
So it wont power on the motherboard? or it could be powered but no display?
No it isnt turning on at all, the mobo's orange led light indicates that electricity is actually running in the board as well as the GPU it shows a green light but it doesnt turn on at all same as there is no electricity
I tested the power supply it worked but once I plug it to the motherboard it doesn't turn on at all while the orange led still stable on board. But nothing turns on at all not even the case's fans
 

ASK THE COMMUNITY