Question Need help with my custom built PC

Dec 3, 2020
7
0
10
0
So at first, when I was using the PC, the screen would randomly go black. I could still hear the game, or videos or whatever I was doing, just couldn't see anything. When I turned it off and on again, it would work normally. Now today, it won't even show anything on the screen, when I turned it on, but it works for sure, cuz I could hear my friends on discord, cuz it auto-joined the server. I tried different monitor, cable and everything. It worked fine for a year until now. Does anyone know what could be wrong or what should I do/try next?
Specs are:
•R5 2600x w/stock cooler
•Asus arez vega 56
•16gb 3000mhz ram
•Asrock b450 pro4 motherboard
•650W bronze certified Coolermaster PSU
• 500gb nvme ssd & 1tb hdd
And I forgot to mention, this summer something similar happened, and the hdmi connector didn't work, so I just switched to dvi and that one worked until now... Also, the screen usually went off when I accidentally hit my desk a bit or something like that.
 

tennis2

Distinguished
How long does it stay black?

Usually a black screen will be followed by a driver crash (if you wait long enough for the process to auto-complete).

If you can bump your desk (that your tower presumable isn't sitting on) and your monitor goes black, then it's obviously your monitor or cable connection to the monitor
 
Dec 3, 2020
7
0
10
0
Well now, it will just show "no input" from the start, so I can't really see anything on the PC, but before when it went black, it never went back, until I turned it off and back on again
 
Dec 3, 2020
7
0
10
0
How long does it stay black?

Usually a black screen will be followed by a driver crash (if you wait long enough for the process to auto-complete).

If you can bump your desk (that your tower presumable isn't sitting on) and your monitor goes black, then it's obviously your monitor or cable connection to the monitor
Yeah the PC is on it, and I think it might be something with the gpu cuz as I said, I tried with different cables and monitors and still nothing
 
Dec 3, 2020
7
0
10
0
No, I haven't yet, I will try during the weekend. do you think that'll fix it? Cuz at first I thought that the connectors might have been fried, because the same thing has happened in the summer, as I said and the other port worked fine until now, do you think my gpu might be dead?
 

tennis2

Distinguished
  1. Power off pc, unplug wall power cable, press power button on case to discharge
  2. Take side panel off case
  3. Unplug power chord from gpu
  4. Unscrew the screw(s) connecting the GPU bracket to the case
  5. Flip the release lever on the end of the x16 slot to free up the GPU
  6. Remove GPU
  7. Repeat all steps in reverse to reinstall.
Takes about 60 seconds if you know what you're doing and there aren't any obstacles in the way of access.
 
Dec 3, 2020
7
0
10
0
That sounds easy, thanks a lot. Hope it will fix it. Will I have any problems with the drivers or anything else? Can this lead to me losing my data or something? Or will the PC be the same as before?
 

ASK THE COMMUNITY

TRENDING THREADS