Question NEED HELP WITH MY RIG:(

Oct 25, 2020
5
0
10
0
So my pc was dusty asf inside of it so I decided I was going to clean it. I blew out the dust inside the cpu cooler and took it off. For some reason the screws are hard to twist so I used a bit of force and maybe have poked my motherboard idk? But anyway I put the cooler back on and tried to start up the PC and when I did my keyboard, monitor and mouse won’t even turn on at all. I tried so many things and it’s getting super frustrating. I don’t know if I broke something but hopefully not. Also there is a light that says “ez debug led” and it’s on dram but my ram is fully in.
specs :
Ryzen 2600
RX580
Msi b450m gaming
g skill aegis 2 x8 16gb ddr4 3200
 

SteveRX4

Notable
BANNED
Sep 29, 2020
1,477
135
890
20
Use a torch and magnifying glass:
Remove your CPU and check for bent, broken or missing pins.
Check that there's no bits of broken pins in your motherboard socket.
Check your motherboard for any signs of damage near the cpu socket.

Replace you CPU cooler with something better.
 
Oct 25, 2020
5
0
10
0
Use a torch and magnifying glass:
Remove your CPU and check for bent, broken or missing pins.
Check that there's no bits of broken pins in your motherboard socket.
Check your motherboard for any signs of damage near the cpu socket.

Replace you CPU cooler with something better.
I don’t think it’s the cpu just because when I removed the cpu once and put it in again the pc started.
 

SteveRX4

Notable
BANNED
Sep 29, 2020
1,477
135
890
20
But anyway I put the cooler back on and tried to start up the PC and when I did my keyboard, monitor and mouse won’t even turn on at all.

Is this still true?
 
Oct 25, 2020
5
0
10
0
But anyway I put the cooler back on and tried to start up the PC and when I did my keyboard, monitor and mouse won’t even turn on at all.

Is this still true?
Okay so I guess I didn’t fully push my ram in. I have my ram some hard force and they pushed in and clicked and I could tell that that was the exact problem. Thank you for your help but the ram just needed extra hard force
 

ASK THE COMMUNITY