Need Help With My System To Run Bf3 On Ultra!

XxartyomxX

Distinguished
Nov 3, 2011
4
0
18,510
Hello,

First of all these are my computer specs

OS: Windows 7
GPU: Evga GTX 560 Ti sli (factory overclocked)
CPU: Intel Core i5 750 @2.67GHz
PSU: Cooler Master Silent Pro M 700W
RAM: 4GB DDR3
Ok so here´s the thing, im playing at 1920x1080 and want to run bf3 at ultra settings, but i can only run it smoothly in high settings, wich is wierd because my computer should run it no problem in ultra.. and yes i have the latest nvidia drivers.., so whats the problem im thinking i may be having a bottleneck with my cpu-gpu or such or should i upgrade my cpu any replys will be appreciated (sorry for the bad grammer)..
 

waxy_27

Distinguished
Oct 25, 2011
34
0
18,540
BF3 isn't very CPU demanding so I don't think the CPU-GPU combo is the problem. Maybe making it 6 gigs of Ram could help (with origin and a browser being open at the same time it would require more then 4 gigs to run it smoothly)

Disable MSAA x4 is you have to, it has almost no effect whatsoever when FXAA is on high

And make sure you have windows 7 64bit
 

sceen311

Distinguished
Apr 19, 2008
291
0
18,790
Not sure your system should be able to handle ultra at that resolution.

The i5 seems decent enough, maybe costing you a couple of frames.
http://www.tomshardware.com/reviews/battlefield-3-graphics-performance,3063-13.html

But the 560ti would appear to be a bit under-powered for ultra.
http://www.tomshardware.com/reviews/battlefield-3-graphics-performance,3063-7.html

I would venture to guess a second 560ti would get you there, it's too bad the article didn't even run a 560ti or 560 given their popularity.

also 6 or 8 gigs would leave you with a little more head room, but as long as you keep your system running trim, and you're not alt-tabing out of the game, I don't think it would make a significant improvement.
 

xperator

Distinguished
Feb 2, 2009
68
0
18,630
Something is wrong with your build and I guess It should be either the CPU or RAM.

With my 560 Ti SLI setup I can run BF3 at Ultra with 2xAA and ambient on at constant 60fps.
How is that your cards can only run on high setting ?
 

spp85

Distinguished
Aug 11, 2011
699
0
19,360


:kaola: Your are crazy a CPU upgrade form a i5 750 to i5 2500 is not worth for the performance gain, especially when the i5 750 is overclocked similar to a i5 2500... Here is an example of a slightly OCed i5 750 @ 3.33ghz vs i5 2500. The performance difference between them is much lower.
http://semiaccurate.com/2011/01/02/intel-core-i7-2500k-review/
 

XxartyomxX

Distinguished
Nov 3, 2011
4
0
18,510
Umm for those who are saying buy another 560 ti i cant there is only 2 way sli idk if i might of spelled it wrong when i put my specs but yeah i have 2 gtx 560 ti and yes they are sli enabled
 

frito11

Distinguished
Nov 3, 2011
1
0
18,510
quite a few websites including tom's here has tested cpu performance and as long as you have a Dual core CPU there is nothing to gain in BF performance wise at least on today's dual and quad core or more designs. i'm running a C2Q Q8200 oc'd to 2.8ghz and 2x 560 Ti's in SLI and performance is very good until i turn on 2x or 4x AA that combine with ultra settings takes too much VRAM for 1GB cards to handle and causes massive lag spikes. im running at ultra everything except AA is off completely at 1920 x 1080 and i was getting 60-100+ fps in multiplayer on a medium size map. in larger maps performance will drop down to high 30's to low 40's at times but gameplay is very smooth throughout so i'm quite pleased.
 

XxartyomxX

Distinguished
Nov 3, 2011
4
0
18,510

Ok so i overclocked my cpu to 3.33 it gave me a lil performance boost but still cant get it runing on ultra, im still having massive lag spikes if i enable hbao and AA 4x it goes all the way down.. maybe more ram will help?
 

TRENDING THREADS