Question Need help with troubleshoot

Oct 21, 2020
2
0
10
0
I built my pc around 6 months ago everything was working smooth no issues until recently around 2 weeks ago.
I was working on my project, fairly nothing much memory taking or cpu power requiring tasks. Had eclipse, Visual studio code and spotify running suddenly screen went blank and then it restarted but screen was all black. Fans were running all pumped up but it just wont boot. (Specs at the end)
Our first guess was maybe graphics card is having some issue, removed it and connected monitor with mobo display--> same results.
It didnt seem like problem with PSU since mobo is getting power with fans and lights all lit.
Then our guess was to check RAM sticks, so my current configuration with RAM was |_ | _ ( | -> Ram stick _ -> RAM slot )
Tried booting with one RAM at their same places still nothing on screen, then we stick one RAM on second slot ( _ | _ _ ) only and it finally it boot up and this is the only slot which is working. I have no idea what is the next step to check for.?
Found some online thread which mentioned to clean up RAM slot but didnt work.
Then my stupid ass noticed Debug lights on Mobo, and when I tried booting with other RAM config than second slot, it shows CPU debug red. When I try with any of 2 RAM slots it light DRAM led.

View: https://imgur.com/a/nxIznE4


Its currently tough for me to get it checked from service centres as they are quite far away from where I live, I would much rather try to solve problem at home if feasible.

Specs:
CPU : AMD Ryzen 3500 with stock CPU cooler
RAM: Gskill Ripjaws V 3600mhz (it was running on base clock and I am not sure about CAS will update later)
Mobo: MSI B450 gaming pro carbon ac
GPU: Galax RTX 2060 Super
PSU: CoolerMaster 750w 80+ gold

Any help would be much appreciated. :)

Note: I dont have much knowledge on hardware side things since this is my first build, had to take my friend's help as well to complete this build and I know all of the parts are not in sync with each other but lets not focus there.
 

lynx1021

Reputable
Feb 17, 2016
850
96
5,290
59
For 1 ram the manual says A2, 2 rams A2,B2. Did you say it booted to screen with 1 ram? If other ram slots are not working it could be from broken pins on the CPU from being installed improperly.
 
Oct 21, 2020
2
0
10
0
For 1 ram the manual says A2, 2 rams A2,B2. Did you say it booted to screen with 1 ram? If other ram slots are not working it could be from broken pins on the CPU from being installed improperly.
Yes only A2 slot is working. So it was working fine suddenly after crash RAM slot stopped working, I dont get it how CPU pins could have been damaged. I dont really move my case if that is one reason of physically breaking it.
 

ASK THE COMMUNITY