Need PC help

grantcstephenson

Prominent
Aug 16, 2018
43
0
540
1
My new pc won’t boot. I made sure everything was plugged in so I’m not sure what the issue is. What I am thinking is the problem is that my cpu power cable doesn’t match what’s on the motherboard. It has an 8 pin and a 4 pin connector on it. My psu only had two 4 pins. Do you think this is the problem? And how can I fix it?
 

flarenial

Distinguished
Mar 15, 2012
107
2
18,715
7


rma it and get it swapped for a new one. if you have no warranty, it's likely trash can filler

 

grantcstephenson

Prominent
Aug 16, 2018
43
0
540
1
Yes everything spins and lights up. I am also thinking it might be the hdmi port. It seems to have a little bit sticking out but part of my case is blocking it from going all the way in. It’s plugged in enough though that I’m not sure that’s the problem.
 

flarenial

Distinguished
Mar 15, 2012
107
2
18,715
7


Hmm my next suggestion would be to make sure all the parts are pressed in and well seated into the slots (ram, gpu, etc)

What kind of psu do you have and what kind of gpu and ram do you have? Also cpu?
 

grantcstephenson

Prominent
Aug 16, 2018
43
0
540
1
Asus rog strix rx580 8gb, Ryzen 7 1700, trident z rgb 2x8 gb 3200. Also I can’t quite remember the psu but I believe it was a seasonic m12 evo bronze 620 Watts
 

flarenial

Distinguished
Mar 15, 2012
107
2
18,715
7


rma it and get it swapped for a new one. if you have no warranty, it's likely trash can filler

 

ASK THE COMMUNITY