Question Need some Troubleshooting Support (multiple issues)

nocturniauzuki

Prominent
Dec 31, 2017
12
0
520
Hello.

Over the course of the past few months to a year, I've been experiencing an ever-growing number of issues with my MSI GE62VR Apache Pro laptop. Being one of those gamers who doesn't actually know anything about computers (besides how to play games with them), my typical response is to google it until I can get it to function, or bypass the issue entirely by using workarounds. However, the issues have been piling up, and it's getting to a point where I can barely use my computer for gaming. In the past, when this has happened, my response would be to think "Well, I guess it's time to get a new computer." But then, in the past, my computers have each lasted me roughly 8 years, as desktops (not replacing or updating any parts, seeing as I don't have the tech skills for that). And besides that, these issues are not simply caused by the computer being so outdated that it can't handle the games.

Three years ago, though, I got my gaming laptop. I was aware that laptops are generally less favourable for gaming, but as I am currently in a transient stage of my life, and will be for the foreseeable future, it made no sense to go with a desktop. In any case, with the background out of the way, here are some of the issues I have, from most recent to longest-standing. Some of these issues are not strictly laptop hardware-oriented, however they are all related to my laptop at least insofar as its the platform they run off of.

I realize these issues are pretty far-ranging, and I'm posting this to the laptop tech support forum, so I don't expect people to know all the answers. But if you're passing by and have experience with one of these particular issues, I'd love it if you could lend me a hand.

1. My PS4 remote's D-Pad down button registers random numbers and durations of inputs, regardless of how long the initial press is.

My controller of choice is the official DS4, and I use it to play any game that has controller support. I have several programs that trick Windows into thinking the DS4 is an Xbox remote, including DS4windows and SCPtoolkit. My default is SCPtoolkit, because it auto-boots when I launch Windows and requires the least fuss. For some games that don't like SCPtoolkit (like Witcher III), I use DS4windows instead.

The issue occurs regardless what game I am playing and which DS4 emulator I'm using. I have tried a different USB port, different USB cable, and factory resetting the controller. None of these attempts has worked. A google search suggested that there might be an internal issue with the controller, but I am loathe to dismantle it without first having a back-up controller on hand. I have no experience dismantling electronics. My own suspicion leans towards some sort of software issue, but I am not sure how to troubleshoot this beyond testing it with both DS4 emulators (which has also failed).

2. The most recent (I think) Windows Update has failed to install repeatedly.

I have tried installing it several times over, and every time has either a) failed, or b) said it succeeded, only for Windows Update to tell me I have required updates the next time I boot up, repeatedly. I have run the Windows Update Troubleshooter, and was hopeful when it said it identified and fixed some issues, but upon booting up, I once again had required updates, and the "new features" (which I know what they are) are not there.

The update in question appears to be this:

Feature update to Windows 10, version 1809 amd64 2019-03 (2)
Last failed install attempt on ‎2019-‎03-‎20 - 0x80240034

I'm getting the error 0x80240034. I have googled this error and will be trying a couple further solutions found here: https://www.wintips.org/fix-error-0x80240034-windows-10-version-1803-failed-to-install/

Though that will have to wait for tomorrow.

3. There is a dead pixel on my laptop screen.

Obviously a physical-only issue. But since I'm making a list of issues, I might as well include it and simply ask: Can a PC repair shop replace a single pixel LED, or would they change the whole screen?

4. My laptop's E and V keys are dysfunctional.

This issue comes and goes, but over time has gotten worse and worse. At this point, I exclusively use a cheap USB keyboard. Without either repairing the keyboard or buying an expensive USB keyboard, I am largely unable to play any game that plays with a keyboard for anything other than in-game chat, so losing my DS4 functionality as mentioned above has even further limited my gaming options.

I did some extensive googling on this issue and discovered that it is a common issue with this particular laptop (MSI GE62VR Apache Pro). The E and V keys lie on the same key circuit, so neither work, although they will work if pressed at the same time as another key (or if mashed enough times...). The exact nature of the issue, however, I am not sure of. Clearly, it's a hardware issue, but what particular kind of hardware issue, I am not sure.

Obviously, this is a significant issue. But is it worth taking it to a repair shop (i.e. will what they do actually fix it)?

5. The laptop has a heat issue.

My laptop goes over 90C when playing games like Final Fantasy XIV and Witcher III. I already brought this up in another thread and had some suggestions, but if anyone else has any suggestions, they'd be welcome.

The previous suggestions were to set a temperature cap and/or voltage cap on my GPU, plus a frame rate cap. Unfortunately, I'm not really sure how to go about doing that. Google tells me I can do it with MSI Afterburner (which I have), but all of the online guides I've found show a different UI to the one I have, so I'm a bit lost. All I've found in that program is a dial for manually adjusting clock speeds, and a massive array of graphs and data that I can set to appear on-screen to track my GPU data in real-time.

Thanks.
 
Mar 19, 2019
27
1
45
Let me see if i can offer any help

1. My first suggestion, since you dont have another controller to try, is to uninstall both DS4 driver utilities you have, then clean install DS4Windows only. Its a little more work to set up as you said, but ive almost never had issues with it myself. Im thinking its possible they might be conflicting. I know i had a similar issue with it when i had Monect PC remote installed, so anything that lets you use your phone as a mouse and keyboard, try uninstalling that as well. we want as clean of an environment as possible for testing.

2. Off the top of my head i cant offer much to this. Im more of a i need to see it kinda guy when it comes to updates.

3 Offhand, i dont think they can replace a single pixel, im pretty sure they have to replace the entire led display for that one, could be wrong though

4. Same as three they would most likely order a new keyboard and replace it. A suggestion i could make is this. At walmart they have a brand of keyboard called blackweb. Its not a razer by no means, but for the 20-30 dollar price tag, its actually a fairly good little gaming keyboard. Might be a cheap but workable solution till you can afford a higher tier one or a laptop replacement keyboard.

5. Temp throttling will keep your temps down, but risks slowing down games as well, as it would force the GPU to not be able to work at its full potential. If thats not an issue for you, and Afterburner wont let you throttle it, you can try EVGA's Precision X!. Does very similar things, just different UI. But if you dont want the GPU and/or the GPU to run anything less thann full throttle, you could try one of those laptop cooling decks. It would improve the cooling effeciency and could help, but those can be a tad expensive.

Bear in mind these are just general suggestions to start with, in the aims of giving you a bit of extra knowledge to work with. If you need any hands on help, ill be glad to help you further, feel free to message me on he
 
1. Can you test the controller on a PS4 system? I'm inclined to suspect the software before the hardware since there's no native driver for it (unlike the Xbox/Microsoft gamepads).

2. You may end up having to install Windows 1809 from scratch (clean install). The failure on some feature updates isn't uncommon - but if you find something that resolves it, please follow up!

3. Stuck pixels can sometimes be fixed with a bit of heat and pressure/massaging the area. Dead pixels are sometimes covered under warranty (depends on location and how many), otherwise you'd most likely have to replace the LCD altogether out of pocket.

4. Most shops/technicians will not dismantle the keyboard to fix any faulty circuits. If there's a problem with the key matrix, nine times out of ten the keyboard gets replaced altogether (unless in the case of the keyboard controller being faulty, then the main board gets serviced or replaced).

5. Setting caps for temps or voltage doesn't really address anything. You can set a voltage offset (or "undervolt") the CPU to help with its temperatures, but you have to play around a bit to find a stable offset. More involved, but usually effective changes, would be repasting the CPU and GPU with a top-tier thermal compound, as well as changing/upgrading thermal pads. If you haven't done any maintenance on the laptop, be sure to clean the fans and heatsinks with an air compressor (nothing heavy duty) or a gas duster (compressed air can).
 

nocturniauzuki

Prominent
Dec 31, 2017
12
0
520
Regarding #1

I also suspect software for the controller, and am trying the clean install of DS4. However, when it comes to installing/uninstalling stuff, my knowledge doesn't extend beyond hitting the obvious buttons. I've read a lot about how software leaves traces behind that clutter up systems, or cause the software to have a ghost presence, but I don't rightly know how to consistently get rid of that stuff. SCPtoolkit apparently does not come with an uninstaller, so I'm trying to delete it via this guide:

https://github.com/nefarius/ScpToolkit/wiki/Manual-driver-removal

However, without the requisite knowledge, this is a scary process. It's asking me to uninstall devices under libusbK in Device Manager. Supposedly this deletes drivers which are then auto-reassigned? But I'm not clear on how this works, and don't want to destroy integral system services permanently. I have, of course, created a system restore point before attempting any of this. But would rather have some more confidence in what I am doing!

Besides, that, while I do feel like it's a software issue rather than a hardware one, I'm also left wondering: If it's a software conflict issue, why is in only happening now? First of all, DS4windows is usually not open. My default controller software is SCPtoolkit. Second, I've had both of these programs installed for years, and I don't recall ever having this issue. I did have a brief period of issue trying to get the controller to work with Witcher III. I'm not sure how I resolved that, but I did... though it has since relapsed, since last time I tried to play Witcher III, my controls were all messed up.

Edit: Actually, my suspicion of hardware failure has just shot up again after carefully examine the feel and sound when I press the key. The Up/Right/Left D-Pad buttons, as well as the shape buttons on the right side, all make a satisfying "click"-like sound when I press them in, and I can feel it clearly when I press them as well. But the Down button doesn't make that sound, and I can't feel the button press clearly. So I suspect there's something broken with the button pad or key internally. Maybe the pad is torn? I may just open it up and see. Or take it in to have it looked at.

Regarding #2

What exactly does a clean install of Windows entail? Do I literally lose all of my installed programs and have to start from scratch as if it was a brand new PC? Because if that's the case, I'm not sure how I could go about it. Though in some ways it might be beneficial for me to back things up on my external HDD and then just start from scratch. It might solve some of my three-years worth of clutter issues.

Regarding #3

I looked up stuck pixels. But unfortunately, even with tests, I can't identify if it's stuck or dead. It's a single pixel on an HD screen. I can't tell what colour it is. All I can say is that I can see it even if the PC is off. So for a long time I thought it was just a speck of dirt. But I've wiped at it as vigorously as I could without damaging the screen, and have not been able to get it off.

Regarding #4

I did drop by a PC repair shop previously, without my PC on hand. They gave me an estimate of $100 to replace the keyboard entirely. That's expensive, but affordable for me. However, it's also more than I'm willing to pay if the problem will simply relapse.

I found this potentially useful forum thread on the issue: https://forum-en.msi.com/index.php?topic=292218.0

The thing that is so odd about this issue is that it is intermittent, and appears to be influenced by laptop load. I'm not sure whether it's heat or if it's a CPU/GPU %usage thing. However, right now as I type this, for example, my E and V keys are working just fine. However, if I start a game and my laptop starts to heat up and/or the CPU/GPU usage start to go up, the keys will quickly start becoming intermittent, or may stop working altogether. I've actually had this keyboard issue for around a year now. You would think I would have long since taken it to a repair shop, but what is so weird is that it goes away on its own from time to time. When the problem originally showed up, I thought about taking it to get repaired, but never found time. Around two weeks later, the problem vanished and my keys worked perfectly in all contexts again. However, it can just as suddenly come back. It's been gradually getting worse, or so it feels like. These days, my E and V keys are out of commission again, and are more or less 100% dysfunctional when the heat starts to increase. I had initially suspected dirt or excessive dust on the keyboard, since the issue came and went. But now I'm not so sure. I suppose the first step would be to clean the darn thing. But unlike desktops, laptops are not built to be disassembled with ease, and I am petrified of breaking something.

Regarding #5

How much are we looking at for thermal paste? I don't have the confidence to apply that stuff (nor do I really know what it is). The simplest solution would probably be to set a temperature limit. I don't typically play the highest-end games, and typically not on max settings. The heaviest game I own is Witcher III. I don't know how many frames I'm getting on average in Final Fantasy XIV, but I could probably throttle it quite a bit without issue.

The trouble is how. MSI Afterburner has the limiters greyed out. Some google searching informed me that they are automatically disabled to avoid inexperienced users (like me?) from accidentally frying their GPUs by turning everything up to max. I've already tried the "Unlock Voltage Control" option, though, and they're still greyed out.



I guess for now what I'll do with all of this is take my laptop in at my next opportunity to at least have them check out the keyboard for any potential hardware issues, and give the whole thing a thorough cleaning. My living space is always hopelessly dusty (comes with being a shut-in most of the time, I guess), but I guess I should take the downtime from not having my laptop and do some cleaning. Meanwhile, regarding the controller, I'll work on the assumption that it's a software issue for now until I have a cleaner, better-functioning laptop and a clean install of only DS4windows (if you could confirm whether or not deleting the items under libusbK is safe or not, I can go forward with that).

Thanks.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS