Need to adjust RAM settings in BIOS to fix BSODing


Oct 6, 2011
Hey guys, I built a new system and it keeps BSODing every time I use any significant amount of memory (mainly graphics intensive video games) and I've discovered that the deafault RAM settings my BIOS loaded are very different than what they should be. I've tried adjusting it myself with no success and was wondering if you guys could tell me exactly what needs to be changed.

Win7 Ultimate x64
Version 6.1.7601 SP1 Build 7601
Motherboard: MSI 890FXA-GD70
BIOS version: American Megatrends Inc. V1.9 4/2/2011
SMBIOS version: 2.5

RAM: Patriot PGV38G1333ELK G Series Sector 5 DDR3 1333 mhz


I just wish there was a BIOS emulator or something out there so you guys could show me exactly which settings to change haha. Anyways, hope this is all the info you need! Thanks in advance!


Oct 6, 2011
I'm not sure where to set the voltages in the bios. When I tried to set them before it resulted in my computer not booting or giving any video signal on start up until I cleared the CMOS. Also what should I be setting the timings to? JDEC1, JDEC2, or XMP (as listed in my cpuz SPD tab)

Also when I set the timings, I have a lot more than just 4 timings to set. I have the CL, tRCD, tRP, and tRAS as normal, but theres also a ton of others all with similar options. Just estimating from memory I'd say about 8 others. Do I have to set anything in those?

Edit: Okay so I restarted again and wrote down everything in the BIOS that I'm talking about.

The options in the bios timings section that I'm confused about are as follows

tRFC0, tRFC1, tRFC2, and tRFC3
1T/2T timing
ganged or unganged
and Bank interleaving

What I attempted changing before were the top 4 timings (to 7,7,7,20, and again to 9,9,9,24), both had no effect on the BSODs.

I looked around for the voltage settings and found:
DRAM Voltage (which when set to 1.65 makes my computer not start up until I clear the CMOS)
DDR VRef Voltage
DDR VTT Voltage

Theres also settings for all the CPU, PCI voltages, as well as north and southbridges.

Lastly theres a FSB/DRAM Ratio option that is currently set on Auto (options being 1:2, 1:2.66, 1:3.33, and 1:4)
Below it reads "Adjusted DRAM frequency: 1066"
This looked wrong to me, so I fiddled with it and when I change the ratio to 1:3.33, the adjusted frequency becomes 1333. Was this a correct thing to do?

Anyways, hope that gives you a more exact idea of what I'm confused about here.


Clear the cmos and shut down... take the ram out and install one module. Start the machine and load Bios. Set the frequency to 1333 with timings of 9-9-9-24 and dram voltage of 1.65v... don't use XMP it's an intel setting and AMD doesn't support it. If you use Jdec the memory is going to default back to Jdec speeds which makes your changes futile.

Once you've made these changes boot windows and test... you can run the windows memory diagnostic or memtest - your choice. The windows test is quick but not as in-depth as the latter.

edit: I don't see your memory on the qvl either:
You're assuming the BSOD is from your RAM, sure if a stick is 'bad' but running under-clocked and at the correct CAS and voltage I'd look at the Event manger.

Setting your RAM:
Adjust FSB/DRAM Ratio so that your DDR3 is 1333MHz
Memory-Z /Enter
enter the correct Timings; 9-9-9-24-2T (CAS-TRCD-TRP-TRAS-CMD)
1T/2T Memory Timing -> 2T (CMD)
DRAM Voltage (V) -> 1.65v ; use closets value per BIOS

Event Manager - look at the Critical errors listed:



Oct 6, 2011
Awesome guys, all of these posts were super helpful. I've done what you said in the BIOS and so far no BSODs. I'll keep stress testing and if I get more I'll post my event manager for you guys. but so far its TONS better :) <3