Question need to replace AMD Athlon 200ge

Page 2 - Seeking answers? Join the Tom's Hardware community: where nearly two million members share solutions and discuss the latest tech.

logainofhades

Titan
Moderator
Nov 30, 2021
21
0
10
0
Sounds like it's working to me unless there are other weird GPU symptoms. If you've got two GPU's in your system some things might run on the iGPU by mistake.
[/Qnto it and the
Sounds like it's working to me unless there are other weird GPU symptoms. If you've got two GPU's in your system some things might run on the iGPU by mistake.
Yes, it's working, but it gets taxed heavily when I am working with photography software. Has to make up for the CPU being weak.
 

Nighthawk117

Prominent
Sep 27, 2021
504
137
590
8
Yes, that's what I am thinking as well. Will I need to upgrade the memory too? As for updating the bios after installing it, is that on the web site for the mobo?
Yes the bios update is on their website, you would need to install that before you put the CPU in otherwise the PC won't boot. I believe this was your board:
https://www.asrock.com/mb/amd/b450 steel legend/#BIOS

You'd know more about photo editing software than me so I couldn't comment on how much RAM you might need to get optimal performance for your workload. If your concerned about RAM speed then it tends to have rather minor impacts on CPU performance unless your running in single channel mode.
Dual channel is especially important for iGPU's because they are quite bandwidth hungry. If you have 2 sticks of DDR4 something though then I wouldn't worry.
 

ASK THE COMMUNITY