Need urgent help

Jul 5, 2018
17
0
10
0
Hello guys first time making a build. I plugged in everything. The mother board is on but I cant seem to get a signal. I don't have a graphics card yet but i have an i7 8700 k and an Asus Maximus X hero mobo.
 

evan1715

Distinguished
May 26, 2011
189
0
18,710
15
ensure everything is securely plugged in. one by one, double check them all onto the motherboard, into parts, and for the monitor.
you can't even see the bios at all?
if your motherboard has it, hit the reset button or a clear cmos button
 

R_1

Judicious
Herald
canned diagnostic speaker rant
The diagnostic speaker is the motherboards main diag feedback device.
the motherboard may be telling you where the problem is.
my speakers have this plug
http://images.crutchfieldonline.com/graphics/infolib/homelib/hSpeakerSpringClip.jpg
I use lamp wire but any stranded wire will do. literally any stranded wires. strip one end like so
http://www.antiquelampco.com/Shades/CordColors.jpg
attach the stripped end into the speaker spring clips on the speaker.
the other end of the wire should be trimmed like so the semi strip
https://wesbellwireandcable.com/images/cutwire.png
by doing a semi strip the wire case is now the socket.
plug one wire to the first pin, and the second onto the fourth pin.
power on the system and listen for beeps
end canned rant
in the case that the case has no speaker

and just to make sure a refresh on grounding

Canned Grounding Rant-
shut down system and remove side panel. with the power cable plugged into the PSU touch a bare unpainted metal area of the case. (my favorite spot is an unpainted screw securing the PSU) once you have grounded yourself you can unplug the computers power cable from the PSU and can touch the system.
if you move your feet, or shuffle in your chair, plug in the cord, reground yourself and unplug again.
end canned rant-
 

ASK THE COMMUNITY

TRENDING THREADS