• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

tsmith154

Distinguished
Jan 5, 2011
132
0
18,690
4
Hello and thank you for any help.

I have connected two hard drives to the router via. the usb ports on the router. I go into the router dashboard. I go to:

USB Storage/USB settings and Enable any USB Device Connected to the USB port (yes)

USB Storage / ReadySHARE Storage and I see my hard drives.
I create a network folder and it does show up.
(USB Device - drive letter shown - file system NTFS -
Folder, I browse and find it -
Share Name, I type one -
Read Access all no password -
Write access all no password-
Apply
I see my new folder created
Apply
Open File Explorer
I don't see the hard disk or drive
I see network and click on it. I see all my hardware devices. I see my media Devices including my XR500. I click nothing, double click takes me to sign into the DUMOS setting where I started from creating the folder.

I checked my computer WORKGROUP and it matching the router WORKGROUP.

I have spent days reading the same thing over and over. Now I am here asking for help.
 

tsmith154

Distinguished
Jan 5, 2011
132
0
18,690
4
WOW! Talk about stupid. Here is the answer:

NETGEAR XR500 router and log in to it (DUMAOS)
Settings
USB Storage
ReadySHARE Storage
Create Network Folder
Answer the questions
BUT! you must create a password
You will be instructed to install NETGEAR GENIE
Choose ReadySHARE
It will show (Network/Device Name: \\readyshare)
Click (\\readyshare)
Now you have access to the USB ports. You can read and write to them.
You can copy the address bar and place short cuts anywhere you want on your computer. Just click that short cut and it takes you there. Or type in the run command (right click windows, choose run, type \\your ip address) it will take you to your USB ports.

NOW go back into your router to the setting and USB Storage. Edit that folder your created and change that part you made a password for. Change it to All - no password.
Now any computer in you network can have access to you USB drives with no password. That's if you want no password that is. All you need to do is right click windows and pick run then type the command \\readyshare. then it takes you to your USB ports and you can read and write.
I copied the address bar and created shortcuts on my computers. Now I just click that icon and it takes me to the USB ports with read and rite access.

It took me days and days to figure this out. There are no instructions out there mentioning this. How bad it that. Shame on you NETGEAR.
 

kanewolf

Titan
Moderator
Hello and thank you for any help.

I have connected two hard drives to the router via. the usb ports on the router. I go into the router dashboard. I go to:

USB Storage/USB settings and Enable any USB Device Connected to the USB port (yes)

USB Storage / ReadySHARE Storage and I see my hard drives.
I create a network folder and it does show up.
(USB Device - drive letter shown - file system NTFS -
Folder, I browse and find it -
Share Name, I type one -
Read Access all no password -
Write access all no password-
Apply
I see my new folder created
Apply
Open File Explorer
I don't see the hard disk or drive
I see network and click on it. I see all my hardware devices. I see my media Devices including my XR500. I click nothing, double click takes me to sign into the DUMOS setting where I started from creating the folder.

I checked my computer WORKGROUP and it matching the router WORKGROUP.

I have spent days reading the same thing over and over. Now I am here asking for help.
Verify that your computer network is set to PRIVATE rather than PUBLIC -- https://www.groovypost.com/howto/change-network-profile-public-private-windows-10/
Try accessing via the IP address \\IPAddress\ReadySHARE in windows explorer
 

tsmith154

Distinguished
Jan 5, 2011
132
0
18,690
4
Verify that your computer network is set to PRIVATE rather than PUBLIC -- https://www.groovypost.com/howto/change-network-profile-public-private-windows-10/
Try accessing via the IP address \\IPAddress\ReadySHARE in windows explorer
Thank you for your help / information. It taken me a couple of hrs. but this is where I am at now. I look at my network using Windows Explorer and on the left side I see the all the stuff like This PC, local drive C, Network. I click on Network and it brings up all my devices such as media device and Network infrastructure. I click on either of them it brings be back to the DumaOS. But! if I just click on "This PC" Then NETWORK LOCATIONS is listed now. I click on that and I see a folder called "Browse Folders". I click on that and I see a folder called the name I gave that hard drive when I formatted it on another computer. Ok, now I click on that and it's empty. I think I finally have the hard drive working and I can use it to put data on it. Like pitcher, files, folders, and such. NOPE. lol. I can't do anything with it. I can't create a folder or place anything inside that hard drive. It is just nothing. No function. So I went back into DumaOS and created a folder inside that hard drive folder. I go back to windows explorer and nothing. No folder was added inside that hard drive folder but DumaOS says there is one.

The Ready Share network path not found.
\\readyshare
I tried entering the default ip address for the router.

I'm still stuck. I can see the hard drive and a folder created inside it using DumaOS but can't use it.
 
Last edited:

tsmith154

Distinguished
Jan 5, 2011
132
0
18,690
4
I tried the Readyshare and It can't find anything. I don't know how to find the IP. address for the hard drives connected to the usb ports on the router. I continued to read about this problem and found some information about this type of communication is outdated and Windows 10 doesn't support it anymore. What? how can a new router that didn't come out long ago be using outdated tech? I would never had bought this router.
 

tsmith154

Distinguished
Jan 5, 2011
132
0
18,690
4
WOW! Talk about stupid. Here is the answer:

NETGEAR XR500 router and log in to it (DUMAOS)
Settings
USB Storage
ReadySHARE Storage
Create Network Folder
Answer the questions
BUT! you must create a password
You will be instructed to install NETGEAR GENIE
Choose ReadySHARE
It will show (Network/Device Name: \\readyshare)
Click (\\readyshare)
Now you have access to the USB ports. You can read and write to them.
You can copy the address bar and place short cuts anywhere you want on your computer. Just click that short cut and it takes you there. Or type in the run command (right click windows, choose run, type \\your ip address) it will take you to your USB ports.

NOW go back into your router to the setting and USB Storage. Edit that folder your created and change that part you made a password for. Change it to All - no password.
Now any computer in you network can have access to you USB drives with no password. That's if you want no password that is. All you need to do is right click windows and pick run then type the command \\readyshare. then it takes you to your USB ports and you can read and write.
I copied the address bar and created shortcuts on my computers. Now I just click that icon and it takes me to the USB ports with read and rite access.

It took me days and days to figure this out. There are no instructions out there mentioning this. How bad it that. Shame on you NETGEAR.
 

ASK THE COMMUNITY

TRENDING THREADS