[SOLVED] Network Adapter Not Working - Possibly After Upgrade

erik62905

Commendable
Jan 17, 2018
161
17
1,715
18
I upgraded my build a few days ago and changed out my CPU, motherboard, and SSD. I didn't change anything else besides installing Windows on the new SSD. The network card worked flawlessly before the upgrade. Anyway, when I was installing Windows on the new drive, I got to the connect to a network page which failed to load entirely (there wasn't even an ethernet option available). Nothing showed under the list. I went ahead and installed Windows locally then installed the driver later. Since I had no connection on the computer I got the driver on a thumb drive and installed it that way, however, I do remember it being a hassle to actually get working, requiring a few restarts and messing around in device manager.

Fast forward to the past 2 days where, upon booting the computer, I've had no WiFi connection. The only way I've got it to work was running the troubleshooter which said it would reset the network adapter properties and settings, then reboot. The WiFi worked after that.

For some more detailed information:
The network card is an ASUS PCE-AC68, the newest drivers of which are from July 2017.
I upgraded from an i7 7700k to a Ryzen 5 5600x. Could the platform switch cause the problem or poor initial compatibility with the new Ryzen processors? The card is plugged into a PCI-e 1x slot, though, which I think means it is connected to the motherboard chipset?
I have tried reinstalling the driver and the issue still persists.
 

erik62905

Commendable
Jan 17, 2018
161
17
1,715
18
latest bios?
install the chipset driver?
I had to install the latest BIOS in order to get the motherboard to support 5000 series processors (unless you mean beta BIOS versions). I've never heard of a chipset driver before but I'll look for that on their website. I'll keep you posted.
 

ASK THE COMMUNITY