Question Network Adapters showing code 45

Jul 8, 2020
2
0
10
0
Hello, new here and I hope this is in the right place.

I have a machine running Windows 10 and my native network adapter on my motherboard was showing code 45, not connected. I tried updating drivers, uninstalling and rebooting, a registry scan, and a system restore to a restore point created several weeks ago.

I finally figured the network adapter was dead, and purchased a TP-Link PCI adapter and insalled, moved my ethernet connection to that, and was back in business. Today, a day later, I had internet just fine until I tried to open a zoom meeting, which crashed the computer. Upon reboot, now both network adapters are showing Code 45.

Does anyone have ideas?

UPDATE:

I did a system restore to an earlier date, and now the newly installed card is working again. I'd still appreciate any insight so that I'm not in a state where it can happen again.

Windows 10 Home Version 1903 Build 18362.900

Intel Core i5-3570k CPU @ 3.40 GHz
16.0 GB RAM
ASROCK Z77 Pro 3 Motherboard
AMD Radeon HD 7800 series GPU
 
Last edited:

Ralston18

Titan
Moderator
Update your post to include full system hardware spec and Windows 10 edition and version.

Wired or wireless connectivity. Verify that only one network adapter (wired or wireless) is enabled. Not both.

Try reinstalling Zoom.

Power down, unplug, open the case.

Clean out dust and debris. Check that all cables, cards, RAM, and jumpers are fully and firmly in place.

Try running "ipconfig /flushdns" via the Command Prompt. [Do not include the quote marks.]

Try running "sfc /scannow" via the Command Prompt.

Failing the above, run and post the results of "ipconfig /all".
 
Jul 8, 2020
2
0
10
0
Thank you, Ralston. I added some system specs to the OP.

Wired connectivity.

A system restore has gotten my ethernet working again, and now I see both network adapters in the device manager (both were hidden, and greyed out when I showed hidden). When I disable the card I installed but leave the motherboard's adapter, I lose connection. When I disable the motherboards and enable the new card, I have connection again.

I cleaned and checked connections originally. Also used /scannow.

For the moment the problem is solved. Hoping it stays that way.

Thanks, again.
 

ASK THE COMMUNITY