• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Network adaptor not working

G

Guest

Guest
I just built a new gaming PC with Z77 Extreme4 motherboard. I got everything set-up fine, but when I tried to connect to the internet, Windows 7 told me to "Install a driver for your network adapter". I installed all of the drivers on the CD provided by AsRock, but there was no driver for the network adaptor so I downloaded it myself from their website. It is still not working. Am I doing something wrong?

Also, the LAN indicators on the back are not lighting up. I am hoping the LAN slot is not dead already.
 

ELMO_2006

Honorable
Aug 29, 2012
368
0
10,810
19
Hi

Is the LAN adapter an onboard card or daughter-card?
Have you performed *Scan For New Hardware Changes*?

Usually Windows will find new hardware in which the device will show up with a question mark. If it is found and listed with a question mark, then you know at least the slot is good.

If it's an onboard card, ensure that it is enabled in the BIOS, if it's a daughter-card, you may want to power down the PC, pull out the LAN card, boot up the PC, then power down again and insert the LAN card followed by another power up. If no joy, power down the PC, remove the LAN card, install into another slot and power up. If no joy, then try the LAN card in an alternate PC or test the slots on the MOBO with an identical card, i.e. USB3 card or whatever hardware you mave lying around that fits the slot(s) used.

Hope this helps and good luck.
 
G

Guest

Guest
If onboard means that it is the motherboards LAN adapter, then it is onboard.
Yes I have. Nothing happens. The "Network Adapter" drop down menu in device manager only appears when I tick show hidden devices.

The LAN adapter does not show up in the unknown devices drop down menu.

It is enabled in the BIOS.

In the AsRock BIOS, when I click on the "System Browser", the LAN adapter has a yellow box around it and says something about 1000mpbs. I assume that means that it is recognising that I have a LAN cable plugged in? I would say what it says word for word, but I cannot enter BIOS at the moment.
 
Q - Are you sure the CAT-5e/6 cable is 'live'? ; if there's nothing connected or the wired network cable is 'dead' then it won't light-up.

If you can either test the CAT-5e/6 cable with another PC (or Notebook) or move your ASRock PC to your Router with a known good CAT-5e/6 cable then you'll know for certain where the problem is in this case.

Open the Device Manager and right click Uninstall; the NIC should be listed without {? or !} symbols and [+] Network Adapters.

Download the correct drivers for your OS and bit size - http://www.asrock.com/mb/Intel/Z77%20Extreme4/?cat=Download
Example Windows 7 64-bit (Broadcom Lan driver ver:14.8.4.1)

Further, before installing ANY other driver, always install the Chipset (INF) driver FIRST; example INF driver ver:9.3.0.1019 for Windows 7 64-bit.
 
G

Guest

Guest
The CAT-5e/6 cable is live. I tested it on my PS3 and it works.

I tried uninstalling the Network Adapters already. It told me that it uninstalled them, but they remained there, even after a reboot.

I am going to reinstall Windows and start fresh and do everything in the order you say.

Could I be setting the BIOS up wrongly?
 
G

Guest

Guest
The System Browser in BIOS says, "LAN Port 1: Connected at link speed 1000mpbs". I assume that means it is recognising the cable?
 
I'd have to boot in my BIOS to notice what it says, or boot into your other PC to compare. I never look at the BIOS LAN 'indicators'. Since most home Routers are 10/100 I'd take that indicator with a grain of salt.

If the BIOS says it works and Windows fails then I'd first test the RAM with Memtest86+ for 2~4 Passes then reformat and re-install the OS. Meaning if the RAM is throwing errors then your OS is corrupted; Memtest - http://www.memtest.org/#downiso
 
G

Guest

Guest
Okay, I will run Memtest. I will post a reply afterwards to let you know whether or not it works.

Another thing while I am here; my BIOS tells me that my RAM is DDR3-1333, yet my RAM is actually DDR3-1600. Why is saying that? Is there any way to change it?
 
G

Guest

Guest
I literally have no idea how to set the BIOS up to get the best out of my components. I cannot find any guides on how to set-up the BIOS for the Z77 Extreme4 either. Are there any guides that you know of which I can use?
 
BIOS - For now there's really not much that needs to be done before you install the OS; clearly there are a few exceptions -- particularly Intel SATA settings. If you ever plan on having any form of RAID (0,1,5 or 10) then Intel SATA -> RAID; SATA Mode Selection -> RAID 'IF' RAID is used. Example SSD + HDD (one of each) 'AHCI' vs SSD + HDD (2) in RAID 1 then use 'RAID.'

DDR3-1333 vs DDR3-1600 and basic settings in BIOS:
Press F9 ; Load Optimized Defaults
DRAM Timing Configuration /Enter
Load XMP Setting -> Profile 1 ; in most cases use Profile 1 or a few cases if applicable Profile 2
Press F10 ; Save & Exit = Yes

Function keys require 'F Lock' to be enabled on the keyboard itself.
 
G

Guest

Guest
Thanks for the information.

I ran Memtest twice and passed twice. I re-installed Windows 7, installed INF first and then installed the rest of the drivers. Windows still tells me that I need to install the driver. It says, "Windows did not detect a properly installed network adapter. If you have a network adapter, you will need to re-install the driver."

When I go to device manager, there are no network adapters or unknown devices shown until I select, "Show Hidden Devices". It shows me this:

Network Adapters

- WAN Miniport (IKEv2)
- WAN Miniport (IP)
- WAN Miniport (1Pv6)
- WAN Miniport (L2TP)
- WAN Miniport (Network Monitor)
- WAN Miniport (PPOE)
- WAN Miniport (PPTP)
- WAN Miniport (SSTP)

Unknown Devices

- IKBMON_01
- IMSMON_01
- IMSMON_02

This is really starting to stress me out. It is my first build and I was looking forward to playing games like they were meant to be played. I might just buy a cheap network adaptor if the problems persist. I may moan to Amazon claiming that it is faulty so they could maybe send me a network adaptor free of charge, because I am definitely NOT removing everything from the board to return it. Especially not the CM212+ EVO CPU Cooler which was hell to install.
 
The IKBMON_01 is a missing keyboard driver, the IMSMON_01~02 are some form of USB devices maybe the KB/Mouse.

I assume that you did NOT use the supplied DVD to install your drivers and instead downloaded and installed the ONLY the latest drivers from ASRock.

Q - What Window 7 EXACT version including the Service Pack?


Also, you CANNOT connect any USB 3.0 devices until Windows finishes installing AND you installed BOTH the ASMedia & Intel USB 3.0 Drivers; i.e. don't connect any device(s) to the Blue USB 3.0 ports.
 
G

Guest

Guest
I used the supplied DVD on my first installation of Windows, but the same thing happened. In fact, when I used the supplied DVD, there was no LAN driver included which I found rather confusing.

I am using Windows 7 Home Premium Service Pack 1

The only things connected to USB 3.0 when installing Windows was my iPod and my USB. But the first time I installed Windows nothing was connected to USB 3.0 and nothing different happened.

I installed both because on another thread on someone recommended that you should.

"From the specs, the Extreme4 has four USB3 ports in the rear - two are driven by Intel, two by ASmedia. That said, you should be installing both drivers."
- http://www.tomshardware.co.uk/forum/244876-39-asrock-extreme4-drivers
 
No Devices can be connected to the USB 3.0 until the drivers are full installed first. Disconnect the devices and re-install the Drivers again.

64-bit or 32-bit?

Example minimum set for 64-bit:

INF driver ver:9.3.0.1019
Broadcom Lan driver ver:14.8.4.1
ASMedia SATA3 Driver ver:1.3.1
ASMedia USB 3.0 driver ver:1.10.1.0
Intel USB 3.0 driver ver:1.0.4.220
VGA driver ver:15.26.12.64.2761

Recommended:
Intel Rapid Storage Technology driver ver:11.2.0.1006

Unknown:
CIR receiver driver ver:20110219 ; CIR generally refers to some form of receiver driver e.g. Smart Remote

Problematic (requires specific installations; see each manual):
Intel Rapid Start
Intel Smart Connect
Instant Boot
 
G

Guest

Guest
I did everything you said, and it is still not working. The network adaptor is still not showing in my Devices. If it is the LAN socket that is messed up, I am worried that the motherboard might be messed up too. Considering this is my first build and I forked out £1000 for it, I really do not want that to be the case.

I requested a replacement from Amazon free of charge.
 
G

Guest

Guest
Thanks. I will receive the new motherboard on the 5th of September and will not have to send my one off until I receive it. It's going to be annoying having to disconnect everything again. I will post a message to let you know whether or not the new motherboard sorted out the problems.

One last thing, I am worried about having to remove the CPU and CPU cooler. The CPU cooler was hell to install. Will it be hard to remove with the thermal paste that is applied to it?
 
Well the second time should be easier (HSF), but anytime you remove a HSF you must also remove and replace the TIM (Thermal Paste).

My advice is to remove both the HSF and CPU before cleaning. I use paper towels,Q-Tips and Isopropyl alcohol to clean the surfaces, cleaning each 2-3 times, and lastly blow-off any dust/lint. If you're really obsessive then use a cleaner: Arcticlean - http://www.newegg.com/Product/Product.aspx?Item=N82E16835100010

You'll need to also purchase new TIM if you're out, I recommend Arctic Cooling MX-4 - http://www.newegg.com/Product/Product.aspx?Item=N82E16835186038

When reapplying use a thin line in the middle of the CPU.~1/2" long.

The 'good' thing is you're gaining a lot of experience and if there's anything you wish you could have done 'better' building -- well here's your opportunity.
 
Yep, you 'SHOULD' replace your TIM. The biggest reasons are oxidation and contamination after it's applied and the only question is how much efficiency will be lost.

Keep it at your own risk. I'm not trying to 'sell' you stuff, but I want you to have the best possible outcome. Further, if you have TIM and an older PC 2-3+ years you can probably lower their temps by cleaning and replacing their TIM...
 

InvalidError

Titan
Moderator

The 212 is not that hard to install/remove once you have figured out the instructions but I agree it can be bothersome at first.

As for thermal paste, it is largely a purist thing since pulling paste apart, putting it back together and spreading it back out by re-installing with used paste will increase the amount of air bubbles in the paste which can reduce cooling performance if there are way too many large bubbles in the paste. If you are not obsessed with getting every last 1C worth of cooling capacity out of your CPU+HSF, paste recycling is fine when done properly.
 
I didn't even want to encourage it...

If you reuse the TIM then scrape it off the HSF using a e.g. (cleaned) Credit Card, clean the HSF as describe above. Using a scarper e.g. Credit Card spread the remainder evenly over the top of the CPU while making every effort to remove bubbles. Then re-install the HSF.

Meanwhile, keep the HSF on the CPU until you're ready to migrate the components to the new MOBO.

TIM spread on the CPU:
 
G

Guest

Guest
It is okay, I am purchasing the product that I mentioned for £14.69 to ensure I get it on the same day as my motherboard. It is a new build and I spent £1000. I would rather be safe than sorry.

One thing though; Are you supposed to put the TIM on both the CPU and the CPU cooler? When I installed the Hyper Evo 212+, I only placed it on the cooler. Was that wrong? Also, how much TIM should I be putting onto it?
 

InvalidError

Titan
Moderator

You only need to put paste on one side, though you might want to apply a thin coat on rough surfaces first to fill the worst scratches/cracks before doing the "grain of rice" application if you choose that method.

As for the quantity, you might be surprised at how little it takes. Best way to find out for yourself is to put a small amount in the middle, mount, remove to see how large the spot became, add a little if the spot does not cover most of the CPU, re-install, re-remove, check again, repeat until you are satisfied with the result. Now that you know the exact amount, clean and re-apply.
 
Generally, it's best to place the TIM on the CPU itself and not the HSF. The reasoning is sizing and alignment. A single line ~1/2" (12mm) in the center of the CPU is ideal for LGA 115X CPUs.
 

Similar threads