Question Network Device cant be controlled on same Wi-Fi

Dec 1, 2021
10
0
10
0
Hi Everyone. Hopefully this is the correct place for this. Any help is appreciated because I posted this on another forum and didn't get any good help.

I purchased a new smart home device that is basically an RF blaster. I have some storm shutters that are remote controlled with a 433hz RF Radio Frequency and I always wanted to control them remotely when out of the house. For this reason, I bought a "MoesGo WiFi RF IR Universal Remote Controller" (Actually made by TUYA ) which allows me to send the radio frequency remotely to my storm shutters.

Problem:
This device cannot be controlled from my phone if im on the SAME Wi-Fi Network as the device. The only way I can get it to work is by shutting the Wi-Fi off on my phone, opening the app to use it, and then turn the Wi-FI back on. This sort of reminds me when I used to have to set up two IP Addresses for remote desktop (one internal, one external w/ port forward).

Possible Issue:
I use an app called Smart Life to control the shutters which is what was suggested by TUYA / MoesGo. For whatever reason, the IP address of this device (According to the app) is my Network's External IP Address. However, according to my router it does have a local IP Address (Ie. 192...).

What Ive tried:
I've Pinged the device and I get a response with no loss.
I've tried doing various port forwards. It doesent make sense that this would be the issue but I was out ideas. I used a port tracer and I think the device uses Ports 6667 & 6668.
I've tried the basics such as resetting and re-setting up the device, power cycle, etc.

Current Network Setup:
I have a Modem which is feeding a Linksys Velop Router (MX5300v1) with (1) Additional node. Everything on my network is connected through the router and most devices tend to use the Node because it has better placement in my home. Smart Home RF Blaster uses the 2.4Ghz band.

THANKS!
 

kanewolf

Titan
Moderator
Hi Everyone. Hopefully this is the correct place for this. Any help is appreciated because I posted this on another forum and didn't get any good help.

I purchased a new smart home device that is basically an RF blaster. I have some storm shutters that are remote controlled with a 433hz RF Radio Frequency and I always wanted to control them remotely when out of the house. For this reason, I bought a "MoesGo WiFi RF IR Universal Remote Controller" (Actually made by TUYA ) which allows me to send the radio frequency remotely to my storm shutters.

Problem:
This device cannot be controlled from my phone if im on the SAME Wi-Fi Network as the device. The only way I can get it to work is by shutting the Wi-Fi off on my phone, opening the app to use it, and then turn the Wi-FI back on. This sort of reminds me when I used to have to set up two IP Addresses for remote desktop (one internal, one external w/ port forward).

Possible Issue:
I use an app called Smart Life to control the shutters which is what was suggested by TUYA / MoesGo. For whatever reason, the IP address of this device (According to the app) is my Network's External IP Address. However, according to my router it does have a local IP Address (Ie. 192...).

What Ive tried:
I've Pinged the device and I get a response with no loss.
I've tried doing various port forwards. It doesent make sense that this would be the issue but I was out ideas. I used a port tracer and I think the device uses Ports 6667 & 6668.
I've tried the basics such as resetting and re-setting up the device, power cycle, etc.

Current Network Setup:
I have a Modem which is feeding a Linksys Velop Router (MX5300v1) with (1) Additional node. Everything on my network is connected through the router and most devices tend to use the Node because it has better placement in my home. Smart Home RF Blaster uses the 2.4Ghz band.

THANKS!
The problem IS the two IP addresses and your router. To have a device on the WIFI access the external IP address is a feature called "hairpin NAT". Some routers don't support hairpin NAT. You may have to change routers.
 
Dec 1, 2021
10
0
10
0
The problem IS the two IP addresses and your router. To have a device on the WIFI access the external IP address is a feature called "hairpin NAT". Some routers don't support hairpin NAT. You may have to change routers.


Just wanted to say Thank You Kane. I started looking into my router settings after your post, which was pretty frustrating because my router is so consumerfied. I was looking for “NAT” and couldn’t find it but Eventually I came across something called Port Triggering. I looked this up on Google and found a Wikipedia article talking about Port Forwarding and NAT. Furthermore, the article used the exact port number (6668) and said it’s commonly routed to Port 113. I plugged these settings in and low and behold it worked!

For whatever reason, it was pretty slow and took about 30 seconds to work, but it worked. From what I was reading, this can only handle a single connection at a time so I’m thinking I’ll try doing an actual range instead of just having the same start /end port which hopefully will speed it up a bit.
Thanks Again !
 

ASK THE COMMUNITY