thelost

Distinguished
Apr 4, 2006
3
0
18,510
Hi there all. I've got a nasty network rash developing. Here's the setup. We have a Linksys BEFSR81 router (connected to cable internet) with 5-6 computers connected to it.

The router has DHCP on so the computers get their ip address from it, the range is 192.168.1.100-108. I have a computer outside that pool 192.168.1.110. I have it outside the pool so I can have a static IP for port forwarding.

The router address is 192.168.1.1.

The problem is that for some reason recently file-sharing has gone kaput with my computer. I have about 10-15 network shares with movies/tv on them that everyone on my house watches but for the last week or so it's been flakey, and now won't work at all.

So far in terms of testing I have done the obvious stuff:

* Pinged the other machines. They're reachable.
* Scanned their ports and my own - port 445, 135, 139 reachable from local network. (Obviously firewalled from internet).
* Checked network settings. All on same workgroup, subnet etc.
* Router - Gone through settings repeatedly, can't see anything that would cause a problem.
* Turned everything off and on again. I even swapped to the second NIC on my PC as it's usually disabled, so I swapped over and disabled my first one.

So I've done all the obvious things I can think of. What have I missed? Also are there any commands for restarting network services, similar to kill -HUP inetd?

I can uninstall the NIC's and reinstall them next I guess. After that though I'm beat. I don't want to have to do a clean install for this but it's really annoying. Is it possible to reinstall just the windows networking components? Or perhaps set them all to their default values? i.e. dump/flush all the networking values so it's as if it's a fresh install?

grrr so frustrated! Hope someone can help me with this. Thanks for reading my long post!
 

cowboytech

Distinguished
Feb 26, 2006
170
0
18,680
Want to try something simple?
On the machine your trying to share from, go to those folders and reset the share, you know, the check in"share this folder on the network" remove it and put it back, and apply, Ok!
Try that please!
 

Social_Engineer

Distinguished
Apr 7, 2006
1
0
18,510
Something you should check. Make sure that "File and print sharing for microsoft networks" is enabled in the LAN properties. just right click on your local area connection icon and select properties and make sure file and print sharing is enabled. You can find it in the control panel under network connections.
 

thelost

Distinguished
Apr 4, 2006
3
0
18,510
cheers everyone! I managed to fix everything finally. Although Windows firewall said it was disabled (zonealarm my firewall automatically disables it) I checked in services.msc and the service was still running. I disabled that and instantly file-sharing began to work again!

cheers for all the help everyone though!