Question New 3080 Not Working???

Jul 6, 2022
2
0
10
0
Just had my new (ex display) MSI 3080 Z trio arrive, plugged it all in and the lights come on, fans come on, but I'm not getting anything out of the card. Tried all of the outputs but there's just nothing.
Also noticed that I don't think it's loading windows or anything properly either, as mouse + kb lights don't come on, and there's no sound coming from the PC when plugging in/taking usb's out (if it was ONLY the display not working, surely the sound should still work?)

Tried updating motherboard (x370 gaming pro carbon) bios but it can't see the media so I'm not sure if that's the problem or not.

Old GPU (Vega 64 Nitro+) still works fine.. anyone have any ideas to help?! If not I'm assuming maybe it's just broke..

PSU i'm using is Corsair RM750x
 
Jul 6, 2022
2
0
10
0
Just to be clear, you have all three 8-pin power connectors plugged in?

Do you have a guarantee that the card was working prior to you buying it?
Yes, all 3 plugged in! 2 cables that both have daisy chains, with 1 left hanging. I looked into this beforehand and read this is perfectly fine to use with no other options? (I do not have any other cables to try). So.... 1 cable that is 2x 8pin, both plugged in, and 1 cable that is 2x 8pin with 1 plugged in....

No, I do not. From a reputable retailer (ebuyer). Have sent an email so will see what they say.
 

SoumithCS

Prominent
Oct 6, 2020
79
14
565
8
Remove the card. Enter BIOS and change the GPU Slot to PCIE 3.0 instead of auto. And then re- slot the 3090. One more thing is can you mention your system specs?
 

ASK THE COMMUNITY