Question new 9600k strange behavior in Games

Wessam_1

Reputable
Apr 13, 2016
37
2
4,545
4
hello guys,

i recently updated from 6600k to 9600k along with Aorus Z390 pro Motherboard, then i noticed bad stuttering (with high frame rates) in shadow of the tomb raider but other demanding games was running fine
i noticed that my cpu was downclocking it self way too much (power saving not throttling) which caused the stutter and frame skipping, temps in games are 50c to 65 max

changed to performance power plan and boom, silky smooth, i told my self maybe its the game fault but now the same problem showing up in witcher 3, which played perfectly fine before! high performance power plan solved it as well,
but the thing is i don't like to run @ max clocks 24/7 when its no need for it most of the time

reinstalled fresh windows with ssd format : no good
uninstalled all software monitoring like msi afterburner: no good
reset bios to default: no good
overclocked to 4.7 across all cores : no luck

all the mb drivers are installed
i also updated the bios to last vesion F9 but i don't remember if the problem started after updating or not

my other hardware
ssd evo 850 - xfx TS 650 psu - msi 1070 ti - 16 gb 2400 ddr4 with xmp enabled , 1440p 144hz monitor

i re checked all the cpu power saving options in bios to make sure its on auto after resetting it multiple times ,different stress tests are also passing fine

all my fans and temps are perfectly fine, i can game for hours with no problems or throttling with the high performance mode, but not with standard mode like everyone else.

any help will be appreciated , i don't want to change power plans every time i game or stop gaming,
 
Maybe you need to run the performance power plan on that CPU for some reason to not get the stuttering. It won't hurt it. CPUs run on high clock speeds continuosly all the time. As long as your temps are good it will be fine.
 

LB3

Honorable
Apr 25, 2014
141
1
10,715
6
No, the performance power plan will run the CPU at 100% speeds no matter what. This option in Windows should usually be avoided unless you're running a full time server or something similar. Power saver is also NOT a good option if you're gaming. Balance is the best for your scenario. Also, be careful in BIOS when making too many changes at once.
You may also be experiencing thermal throttling due to too much voltage. I would suggest putting everything in BIOS back to default. Then start by turning on XMP with Balanced power plan and see where that leads you. If everything is good then you can start OC'ing the CPU again.
 

Wessam_1

Reputable
Apr 13, 2016
37
2
4,545
4
after digging online for similar cases i found out that it has something to do with last windows 10 update. april update or somthing, that affect some cpu's that way in some games, after i reinstalled windows i checked witcher 3 and it was good, problem started to show up after windows finished it's big main update.

i disabled all power saving stuff for the cpu , running @4.7 all the time on a fixed 1.248v core voltage, and it solved all the stuttering in games.
 
Reactions: LB3

Similar threads


ASK THE COMMUNITY

TRENDING THREADS