Question New Amd Athlon 3000g with asus prime a320mk drivers not installing properly,black screen issue.

soumojit

Distinguished
Jun 9, 2012
21
0
18,510
0
URGENT Help

HI,

I Assembled cpu AMD athlon 3000g with asus a320mk. I installed win 10 20h2 fresh booted fine.. after installing all components sound and Lan vga driver successfully from asus cd right after installing vga driver my pc got reboot then display hang with black screen.. did system restore then tried even downloading from Asus websites vga driver but still same problem .. again after system restore now tried with automatic windows update. Well it progressed with installing vega 3 driver in device manager I checked , but after few seconds again rebooted, then bam same issue with black screen hang.

Please help , I can boot windows fine but problem arises after installing vga driver from motherboard.. please help what's the actual issue is

CPU MOBO BOX pic

Thanks in advance.
 
Last edited:

Satan-IR

Distinguished
Ambassador
Please list your full system specifications including make and model of:
Motherboard:
CPU:
RAM:
Graphics Card:
Power Supply:
Storage:
Case:
OS:

Which BIOS version do you have? The CPU support page for that board from here says you need BIOS version 5603 for an Athlon 3000G. Perhaps if you have older BIOS installing the one mentioned by manufacturer would help.
 

soumojit

Distinguished
Jun 9, 2012
21
0
18,510
0
Please list your full system specifications including make and model of:
Motherboard:
CPU:
RAM:
Graphics Card:
Power Supply:
Storage:
Case:
OS:

Which BIOS version do you have? The CPU support page for that board from here says you need BIOS version 5603 for an Athlon 3000G. Perhaps if you have older BIOS installing the one mentioned by manufacturer would help.
I posted a pic of box of my cpu mobo my ram is 16gb dual channel gskill.

But if BIOS version mismatch happens wouldn't my pc won't boot up at all right ? Or I'm wrong..? Can I use system restore and download BIOS update ?
 

soumojit

Distinguished
Jun 9, 2012
21
0
18,510
0
Please list your full system specifications including make and model of:
Motherboard:
CPU:
RAM:
Graphics Card:
Power Supply:
Storage:
Case:
OS:

Which BIOS version do you have? The CPU support page for that board from here says you need BIOS version 5603 for an Athlon 3000G. Perhaps if you have older BIOS installing the one mentioned by manufacturer would help.
5603v already installed
Yeah but I need to install display adapter driver before from asus site right? if I'm not wrong that's the process
I already have 5603v version
 

soumojit

Distinguished
Jun 9, 2012
21
0
18,510
0
CONTINUING MY POST, ISSUE GOT RESOLVED , by simply changing board to asrock b450 hdvr 4.0.. no error on installing drivers..

But my question still remains what was the problem in asus prime am320 k ? In my knowledge it was out of the box support of vega 3 integreated graphics and athlon 3000g then why didt let me install drivers.. or i was supposed to install chipset driver of asus ( 50 mb )before doing vga driver install ?
please reply
 

ASK THE COMMUNITY

TRENDING THREADS