Question New build - bad PSU?

Aug 24, 2019
2
0
10
0
Board: MSI B450M Pro M2 V2
CPU: Ryzen 3 2200G
RAM: Patriot 4 Viper ddr4 3000mhz 2x4GB
PSU: Corsair CXM 550 80+ Bronze

So, new build. Tested outside the case, worked fine. Put it all together in the case, worked fine, posted, got into BIOS. It was late so I packed in for the night and went to bed.

Got up this morning, turned it on with the intention of installing Windows and it died while in BIOS and wouldn’t power on again - I did get the briefest of blinks from the power switch lights and the CPU and case fans. Checked all connections several times, seemed fine, still nothing. Briefest blink of power and nothing.

Disassembled everything, rebuilt outside the case, used a screwdriver to jump start the power and same thing: blink of lights, couple of turns on the fans and dead. Tried every troubleshooting tip, one stick of ram in each slot, no ram, just the CPU and fan, remove CMOS battery, tried plugging it in different rooms, different kettle lead etc. same result.

I can’t see any obvious physical signs of any issues: capacitors on the mobo are fine, connections all good, no weird smells coming from the mobo or PSU.

I’m guessing this might be the PSU at fault? I don’t have any other parts to test on this unfortunately.

Are there any steps I might have missed or any other suggestions you can give?

Much appreciated.
 

PC Tailor

Dignified
Herald
Welcome to the forums my friend!

If you don't have any other parts to test, guesses would be on PSU first. So it's a case of swapping and testing.

A paperclip test will check if the PSU can fire up, or a PSU tester that gathers voltage readings on each rail can help, but may be more hassle than it's worth if they're new parts.
 
Reactions: yosoydavid

PC Tailor

Dignified
Herald
Hey, many thanks for the reply. I’ll ask around to see if I can source a PSU to test or take it to a local repair guy to test.
Just remember the paperclip only tests if it can fire up, not that it's outputting the correct or stable wattage, but it's a very simple way for you to test if it fires up at all, if it doesn't, you know it's the PSU :)
 

ASK THE COMMUNITY

TRENDING THREADS