New build booted up fine yesterday, but not today

lister000

Distinguished
Sep 21, 2011
1
0
18,510
So, yesterday I put together my new build and got it to boot up on the first try. I was able to install Windows and didn't notice any problems.

Today, when I got home from work, I don't get anything when I push the power button. No beep, no LED light, no fans spinning even for a second. I've tried removing and re-seating the power switch wire from my case, tried turning my PSU on and off, tried using a different socket with a different power cord, all to no avail.

Any suggestions as to what the problem might be, or what I could do to narrow the issue down? If needed I can give any specs that might be of interest.
 

AdrianPerry

Distinguished
Might be a stupid question but is the wall outlet your using 100% supplying power? (Have you tried another electrical item on the wall socket to test it?)

Have you checked the voltage switch on your PSU if it has one? (115v/230v)

If none of these work, and the wall outlet is 100% supplying power, i suggest removing the PSU from your build, and plug something like a molex fan into it and see if it powers up. If it doesn't, then I think you can conclude you've got a faulty PSU.

NEVER EVER open up your PSU unless you know EXACTLY what your doing. The link below might help you troubleshoot your problem.

http://www.computer-how-to-guide.com/power-supply-troubleshooting/failed-power-supply-psu-diagnostic/