[SOLVED] New Build, cannot get SDD to stay as primary boot option, keeps reverting back to HDD in bios.

Nov 27, 2018
2
0
10
0
My cpu is a new build. Asus B450M mobo, I have a 120GB ssd ( C: ) and 1TB hdd ( G: ). I loaded windows via usb and stored it on the SSD. The HDD is being used as supplemental storage and doesn't have the OS on it. When I power down my pc and turn it back on it gets stuck on the ASUS screen where I could normally press F2 or Del to get to the bios menu. It freezes on this screen, pressing F2 or del won't take me to bios settings. I can then hold the power button and reset my PC and press F1 to launch pc in recovery mode and it takes me to my bios. Once I'm in the bios I can see that my HDD is set to primary boot instead of my SSD. This is a problem since my HDD does not have the OS on it, Im assuming that is why it just freezes. I can swap the boot priority and save and the cpu will launch windows and run fine. As soon as I shut down the PC and restart, it changes the boot priority back to the HDD. I was told this may have something to do with the fast boot. Currently it is enabled on the asus bios screen. I have not checked the windows 10 fast boot yet. I wanted to know if this information was true before I went changing things.
 

USAFRet

Titan
Moderator
Mar 16, 2013
114,510
2,110
157,240
18,630


Are you sure about that?
Not even the System Reserved boot partition? Did you look in Disk Management, because that often happens.
 
Nov 27, 2018
2
0
10
0


I did, but I chose the SSD as my C drive and installed to that drive and then had to go in and format the HDD and rename it G to use it. None of the OS software is on the HDD.
 

USAFRet

Titan
Moderator
Mar 16, 2013
114,510
2,110
157,240
18,630


Are you sure about that?
Not even the System Reserved boot partition? Did you look in Disk Management, because that often happens.
 

ASK THE COMMUNITY

TRENDING THREADS