New build cpu/case fans not spinning no output

Sep 24, 2018
7
0
10
0
Hello, so this was a new build and after I got done my motherboard and ram's rgb would turn on yet my case and cpu fans didn't start up. I booted it without the card since it shipped later, just as a test. I did a triple take after I got home plugged in gpu and tried again and same thing only the gpu fans didn't spin either and no output

My build is
Case: Phanteks Enthoo Luxe PH-ES614LTG_AG
Mobo:ASUS ROG Strix X470-F
Cpu:AMD RYZEN 5 2600X 6-Core 3.6 GHz
Ram:G.SKILL TridentZ RGB Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 2400 (PC4 19200)
Psu:Thermaltake Toughpower Grand RGB 850W Smart Zero Fan
Gpu:ASUS ROG GeForce GTX 1060 STRIX-GTX1060-O6G-GAMING 6GB 192-Bit GDDR5(was not in system yet)
Ssd:Kingston SSDNow V300 Series 2.5" 120GB SATA III (only old piece)

1)double checked cables and connections
2)unplugged my ssd and ram
3)unplugged unnecessary mobo connections and changed psu cables
4)triple checked 8 pin cpu power

I'm planning to try my old power supply tonight.
 
Sep 24, 2018
7
0
10
0
I didn't mean to type the integrated, I was just doing a test boot without it connected to anything to see if everything powered up okay. Sorry first time using the site and I typed that up in a rush at break.
 
Sep 24, 2018
7
0
10
0
Okay so I just installed the gpu and tried to boot it up. I get nothing at all and no case or cpu fans start. My aura on my ram and mobo come on, a light on my gpu above the plug comes on but its fans dont turn on either. My DVD drive I just popped in starts up and makes a few sounds.
 
Sep 24, 2018
7
0
10
0
Was able to solve to fan issue. Plugged in my ancient Apevia Iceberg Power ATX-IB680W and was able to power everything other than the gpu, didn't even try since it only has a 6 pin and no 8. So it seems I have at least a dead modular power cable for my cpu socket.
 
Good that you got to the bottom of it as there nothing was than having a PC problem you cant understand...Hope all goes well as the Power supply is good...wonder if it is just the cable? Let me know if you can as I have the very same Power Supply...just bought it as it was on offer...
 
Sep 24, 2018
7
0
10
0
Will do, I'll be picking up a spare cable from a friend and see if everything starts up right tomorrow night since I couldn't actually test the full build yet.
 

ASK THE COMMUNITY

TRENDING THREADS