Question New build freezes after bios spash screen..

Mar 11, 2019
2
0
10
Best answers
0
Hey guys, now I know this might be a duplicated post and I’d like to apologize if that is the case in advance.I have this problem that I’m struggling with for a few weeks now.

Bought every part to build my first pc, I’ll post the specs below. After building it up, it worked flawlessly for about 2 months after which at one point it just froze. I had to force restart it by holding the power button, when trying to boot it back up, it would freeze about a second after the “press f2 or del to enter bios” screen, when those spinning dots appear. I panicked back then and restarted a few times (10-15 times) after about the 10th time it froze a little later than usual, after the 15th time it successfully booted and worked fine for about a day or 2, when exactly the same thing happened again, right after “press f2 or del to enter bios” it gets stuck. I’m losing my mind and can’t afford to buy things to test things out, any idea what might be broken?

Things that I’ve tried:

-remove battery on mb for 15 seconds;
-boot with only 1 ram stick;
-boot with 2 ram sticks;
-boot with all ram sticks but on different sockets;
-boot without the gpu;
-stay in bios for more than 10 minutes and boot again;
-remove the 960Evo;
-after removing 960Evo, erase 970Pro through bios and boot into usb windows installer;

Notes: bios had no problems regardless how long i stayed in it and it would properly detect my cpu and rams ( it would show the label “i7-9700k” of the cpu and like the ram details “32000MB HyperX bla bla”, frequency and all that).

Specs:
Mb: z390-e asus
Cpu: i7-9700k
Ram: 3333mhz 4x8gb hyperx
Cooler: corsair 360mm h150i pro
Gpu: 8gb 1060 (was about to upgrade this)
Psu: EVGA Supernova 650W 80+ gold
Ssd: 1x 970Pro 500gb; 1x 960Evo 250gb

EDIT: Updated some more things i've tried.
 
Last edited:
Mar 11, 2019
2
0
10
Best answers
0
Please excuse my super delayed response..

@XD I know pc's: What do you mean by safe mode? It can't be a windows problem since the same thing happens when I try installing a fresh copy of windows from a usb stick.

@Dark Lord of Tech : I never manually installed any driver. I built it and it just worked until all this. Also, quick note: when I was trying to find what can be broken, I took one of the M.2s out, and only kept the 970 Pro. Erased it through bios safe erase, plugged in a windows usb and tried booting. Exactly the same thing, when trying to boot into the stick for installation, after the F2 or del screen, freeze.
 

ASK THE COMMUNITY

TRENDING THREADS