Question New build GPU sparked and computer turned off.

Jun 21, 2021
2
0
10
0
I just built a new computer and put everything together fine but after a few hours of casual gaming the GPU sparked and I smelled burnt plastic. The PSU is a seasonic 750 watt and the GPU is a Radeon rx 6700 with an MSI b450 tomahawk motherboard. I used the cables that came with the power supply so I don’t think a brand new seasonic would be the issue. Any ideas on what could’ve caused it and where to go from here?
 

revodo

Proper
BANNED
Jun 10, 2021
241
34
120
2
That's not a good sign. Of course I accidently sparked a motherboard building a system a few years ago (never assemble computers when you're sleep deprived), and it's still up and running with no noticeable issues.

Definitely going to have to take the computer apart and take a picture of the affected area.
 
Reactions: Lordwadsworth
Jun 21, 2021
2
0
10
0
Could be a faulty cable or connector.

Can you post a pic of the damaged area?

I checked all the cables and looked all over the motherboard and didn’t find any discoloration or a possible point of failure or anything picture worthy at all. I didn’t have a screwdriver on hand small enough to open up the GPU to look inside to see if anything is blown so I took the GPU out and put in a old cheap GPU and the computer turned on fine. Since it’s my friends build and he wanted to try the old GPU and the computer wouldn’t even turn on. He submitted a warranty request and they’re sending a new video card.

Could it just have been a defective unit or is it more likely there could’ve been a short somewhere? What can I do next to prevent it from possibly happening again. The case is a nzxt H510 and has preinstalled standoffs from what I read online if that matters at all.
 
Last edited:

ASK THE COMMUNITY