Question New Build- Grey screen upon startup. blue screen when trying to install windows, boot problems and freezing

Feb 23, 2019
2
0
10
0
Hi All, I am having problems with my first ever PC build and am trying to figure out which parts I need to replace. Below are all the specs and the problems I have faced.
Specs:
AMD Ryzen 5-2600 6 core processor
MSI B450M PRO-M2 motherboard
Crucial 2x 8GB single DDR4 2400 RAM
Colorful Nvidia GTX1060 3gb VGA Card
WD Green 240gb SSD
Seagate 3.5" BarraCuda 1TB
Thermaltake Versa H21 case
Thermaltake TT500nl2nk 500W PSU
LG 22" LED 1920x1080, 75Hz,2ms VGA/HDMI/FreeSync Monitor

The graphics card fan spins for a split second when the PC is powered on and then stops. This could be due to smart fan but it has not once continued spinning past this tiny rotation.

The RAM has been checked with memtest86 and there are no problems there.

The monitor works with other PC's and all cables are connected properly.

Alongside blue, grey and black screens. The PC freezes on startup, in bios settings and when trying to install windows.

The windows media creation tool USB is not booting to windows properly even though it is the first priority in the BIOS, instead I get a black screen with writing saying to insert a boot device.

The UEFI says that the CPU temperature is low 30's so it isnt an overheating problem.

It could be a faulty PSU. The PSU came with the case so is pretty cheap and although it says 500W, apparently it can only reach 400W maximum.

CMOS has been reset to default and so has the UEFI.

Please help me figure out the faulty component. I am thinking that it is either the GPU, motherboard or PSU. Thank you
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS