Question New build Issue. Any Advice appreciated

Mooser101

Distinguished
Jun 20, 2011
12
0
18,510
0
Good evening yall,I have recently decided to build a new pc and ran into some issues
Specs:
Intel core i-7-10700k
Asus rog strix z590-a
g.skill trident 4x8gb 3600
seagate firecuda 520 1tb m.2
nvidia geforce 1080 fe
cooler master v850 gold semi fanless modular

so when i unpacked the mobo, i noticed a pin in the top right corner folded over but i thought it was part of the mobo . i installed components and booted pc up. i could get a poast but no display on screen through gpu or mobo. My mobo was giving a qled of dram error.
After trying for countless hours to trouble shoot i gave in and sent the board to place of purchase as an rma. what they said shocked me. the pin i thought was design the way it was , was in fact bent and they would not cover replacement or rma. i got the board back and proceed my slight of hand to bend the pin back to its proper orientation.
i got the pin folded back over and in the relative proper position that i was happy with it. reassembled my pc with high hops of gaming. I hit the power button and the board is not giving me qled for vga and boot. It is no longer poasting, nor am i getting a display through gpu or mobo ports. Looking for suggestions at this point. do you think the pin is not lined up proper or do i have another issue with board. the gpu is out of my current pc and in fact works properly.

Thanks Adam.
 

Mooser101

Distinguished
Jun 20, 2011
12
0
18,510
0
Did you rma through the vendor and get refusal in writing? If so, contact Asus directly, and include the refusal.
I did rma through vendor and yes I have a copy of the refusal.
Last night after trouble shooting I got the dram light off, after bending pin back, vga light went off after installing a different gpu, bot light stayed on. no m.2/sdd with os installed. still was not getting a display of bios through integrated or gpu.
I reseated ram sticks and push bios flashback. now I am back to dram qled.
 

Mooser101

Distinguished
Jun 20, 2011
12
0
18,510
0
Update. ; Yesterday afternoon i went at the cpu socket with a sowing needle and my phone camera on full mag x. need to find a magnefineglass . I will say i never thought playing Warhammer growing up would be a skill i would need in the future but i still have my hand dexterity. after 2hours of trying to realign the cpu pin that was bent i was surprisingly shocked when i turned pc on and got into bios. now i have windows installed , programs load but i cannot get my pc to recognize my firecuda 520 1tb m.2 in slot 1. i tried switching slots that didn't help. starting to wonder if im missing a driver or something. the ssd is not found in bios or windows device manager.
 
i cannot get my pc to recognize my firecuda 520 1tb m.2 in slot 1. i tried switching slots that didn't help. starting to wonder if im missing a driver or something. the ssd is not found in bios or windows device manager.
you can try updating to the latest BIOS and see if a problem with the M.2 slot(s) has been addressed and fixed with a later version.

and\or you can try a drive connected via SATA ports to test if there is a hardware issue with the M.2 controller or port itself.
if this allows you to install the OS, then try all of the latest motherboard's drivers.
possibility it could enable the M.2 port and allow your Firecuda to be recognized.
 

ASK THE COMMUNITY

TRENDING THREADS